UniversoExcelForo

Respuesta a consultas.
Fecha de creación: 09.Abril.2012

Fundadores: Wibly,Tyno,Servando,Sakkar,Rosendo2,RMaximo,Railar,Mcoronel,Ioyama,Igtelo,Hugotron,Drochar,Dedos,Alberto,Adolfo

No se pueden hacer consultas de Excel o VBA por mensaje privado.
Utiliza el botón buscar del foro y te ahorras tiempo para obtener "ayuda".

No estás conectado. Conéctate o registrate

Ver el tema anterior Ver el tema siguiente Ir abajo  Mensaje [Página 1 de 1.]

1RESUELTO Problema con funciones el 25/06/14, 11:18 pm

ANDESTEBAN


muy buenas tardes estimados, les comento, tengo un problema con mi función lógica, necesito que cuando se cumplan 3 F consecutivas, la fila se vuelva negra completa, pero me corre el color una celda arriba, porfavor ayuda!
Archivos
Planilla.xlsx
No tienes los permisos para descargar los archivos.
(234 KB)

2RESUELTO Re: Problema con funciones el 26/06/14, 03:17 am

ioyama


Hola Esteban

Revisa el adjunto. Como estoy usando un Excel 2003, te he agrupado dos condiciones que devuelven el mismo color y te he añadido la condición de las tres F (no es muy elegante, pero funciona).

Un saludo desde Vitoria
Archivos
FormatoCondicional_io_140626.xlsx
No tienes los permisos para descargar los archivos.
(234 KB)

3RESUELTO que tremendo!! el 26/06/14, 04:33 pm

ANDESTEBAN


si, a grandes rasgos eso era exactamente, ahí modifique un par de cosas pero fue exactamente lo que buscaba muchas gracias!!

una consulta más, con respecto a lo mismo, estaba buscando información con respecto a los ciclos if, porque se me ocurrió que quizás podía poner una alerta(cambio de color a negro) al faltar solo los días lunes, pero cuando intento cambiar el color siempre es de forma correlativa, o con un identificador único. como podría hacerlo para que distinga solo los días lunes, por ejemplo, si falta dos lunes seguidos, se cambian a negro toda esa semana.

no se si sse pueda la verdad pero para salir de la duda mejor pregunto, muchísimas gracias, mi error principal era el orden  no aplicaba de atrás hacia adelante como vi en tu formula.

4RESUELTO Re: Problema con funciones el 27/06/14, 03:42 am

ioyama


Hola Esteban

No acabo de enetender lo de los lunes. Podrías explicarte un poco mejor (un ejemplillo hecho a mano podría ayudar)

un saludo desde Vitoria

5RESUELTO Re: Problema con funciones el 27/06/14, 01:25 pm

ANDESTEBAN


En en el item 1, Lemus Gutierrez asistió(A) toda la semana, con excepción del lunes 30, lunes 7 y lunes 14, necesito que cuando se cumpla la condición de falta(F) por 3 lunes consecutivos, la fila completa cambie a negro o también podría ser que las F de esa fila cambien a negro.

espero explicarme bien, muchisimas gracias
Archivos
FormatoCondicional_LUNES.xlsx
l
No tienes los permisos para descargar los archivos.
(230 KB)

6RESUELTO ayudaa el 03/07/14, 05:27 pm

ANDESTEBAN


tengo el problema casi resulto, el único problema ahora es que no se marca la fila completa, la idea es que cuando se ingresen 3 F en cualquier fila, toda la fila se vuelva negra pero solo marca la primera F para atrás.
Archivos
Planilla.xlsx
No tienes los permisos para descargar los archivos.
(244 KB)

7RESUELTO Re: Problema con funciones el 04/07/14, 03:04 am

ioyama


Hola Esteban

Usa referencias absolutas en la tercera condición tal que =CONTAR.SI($F16:$AM16;"F")=3
y pon esta condición en todo el bloque

Tu estás usando =CONTAR.SI(F16:AM16;"F")=3 en la primera celda, =CONTAR.SI(G16:AM16;"F")=3, en la segunada,
=CONTAR.SI(H16:AM16;"F")=3, en la tercera, etc.
...
vas acortando el rango para contar las F.

Un saludo desde Vitoria

8RESUELTO Re: Problema con funciones el 04/07/14, 11:55 am

ANDESTEBAN


lo que hice finalmente fue hacer un calculo de total de F por linea y si esta llegaba a 3, pintaba de F7 a AM7, 


MUCHISIMAS GRACIAS!!

Ver el tema anterior Ver el tema siguiente Volver arriba  Mensaje [Página 1 de 1.]

Permisos de este foro:
No puedes responder a temas en este foro.