UniversoExcelForo

Respuesta a consultas.
Fecha de creación: 09.Abril.2012

Fundadores: Wibly,Tyno,Servando,Sakkar,Rosendo2,RMaximo,Railar,Mcoronel,Ioyama,Igtelo,Hugotron,Drochar,Dedos,Alberto,Adolfo

No se pueden hacer consultas de Excel o VBA por mensaje privado.
Utiliza el botón buscar del foro y te ahorras tiempo para obtener "ayuda".

No estás conectado. Conéctate o registrate

Ver el tema anterior Ver el tema siguiente Ir abajo  Mensaje [Página 1 de 1.]

borboleta85


Hola gente,

Voy a intentar explicar la condicional porque son muchos datos y subiendo una muestra no puedo mostrar mi problema.
Basicamente tengo dos columnas de fechas A y B en la columna A tengo 53000 fechas y en la B tengo 5973 fechas.
La condicional seria si($A2=$b$2:$b$5973;"observador";0) en matricial que lo que quiero es cuando en la columna B aparece una fecha (normalmente varias veces la misma fecha) que tambien aparezca en la columna A que ponga observador y si no que ponga 0.
No entiendo que hago mal porque no me sale la palabra observador en ninguno de los 53000 datos cosa que es imposible porque si que hay fechas que coinciden.
Muchas gracias si teneis alguna duda no dudeis en preguntar¡

tyno


Hola borboleta.
Me parece que el tema es más fácil de lo que parece, lo que yo haría es un CONTAR.SI, es decir si una fecha de una celda de la columna B se cuenta  una o mas veces, implica que dicha fecha de la celda de la columna B se encuentra en la columna A:

=SI(CONTAR.SI($A$1:$A$53000,B1)>0,"Observador",0)

wibly


Hola borboleta85, qué tal tyno!

borboleta, dices que subiendo una muestra no puedes mostrar tu problema... siempre es preferible que subas la muestra para trabajar sobre la misma.

Entiendo que el problema de tu fórmula es estar comparano una celda ($A2) con un rango ($b$2:$b$5973) y creo que lo que hace es solo compararte la celda A2 con la B2 (primer celda del rango).

Creo que la fórmula planteada por tyno debería funcionarte correctamente, solo deberías tener en cuenta la última fila a considerar. Luego indica si has resuleto tu problema.

Saludos

Adrián

borboleta85


muchas gracias¡funciono lo que me dijeron.

Gracias, un saludo.

Ver el tema anterior Ver el tema siguiente Volver arriba  Mensaje [Página 1 de 1.]

Permisos de este foro:
No puedes responder a temas en este foro.