UniversoExcelForo

Respuesta a consultas.
Fecha de creación: 09.Abril.2012

Fundadores: Wibly,Tyno,Servando,Sakkar,Rosendo2,RMaximo,Railar,Mcoronel,Ioyama,Igtelo,Hugotron,Drochar,Dedos,Alberto,Adolfo

No se pueden hacer consultas de Excel o VBA por mensaje privado.
Utiliza el botón buscar del foro y te ahorras tiempo para obtener "ayuda".

No estás conectado. Conéctate o registrate

Ver el tema anterior Ver el tema siguiente Ir abajo  Mensaje [Página 1 de 1.]

rguayabo


Hola comunidad;
resulta que tengo un listado de 323 números en la columna B, pero solo quiero tener en cuenta solo aquellos números que contengan el números 47 o 74. que son la referencia a buscar en el listado; y este numero 47 o 74 estará en otra celda. sin importar si están juntos o separados por ejemplo el numero 407, contiene el numero 47; 407, el numero 467 que contiene el numero 47 o 74 así 467, el numero 470, por que tiene el 47 o 74 470. el 784 contiene el numero 47 784
tengo esta formula pero me devuelve los números que tiene el 74 es decir del listado me devuelve todos aquellos que tengan 4, 7,. independientes.
{=SI.ERROR(INDICE($CE$1:$CE$324;QUE.ESIMO.MENOR(SI(SUSTITUIR(SUSTITUIR(SUSTITUIR($CE$1:$CE$324;EXTRAE($AX$1;1;2);"");EXTRAE($AX$1;1;2);"");EXTRAE($AX$1;1;2);"")<>""&$CE$1:$CE$324;FILA($CE$1:$CE$324)-3);FILA()-3));"")}

001
002
006
008
014
016
019
020
024
029
041
046
048
061
064
066
079
080
086
088
089
091
092
097
098
100
104
106
108
109
140
144
146
149
164
166
184
186
188
189
190
194
196
198
199
208
209
240
244
246
248
260
264
266
268
269
286
288
289
290
294
298
299
401
406
407
408
410
416
418
419
420
424
426
428
441
442
448
460
461
466
467
469
470
476
479
480
481
482
484
486
487
488
489
491
496
600
601
602
604
606
607
608
614
616
619
620
624
626
628
629
640
641
646
647
648
660
661
664
668
669
670
680
681
682
684
687
688
689
691
694
696
698
699
704
706
709
746
748
749
760
764
768
784
786
788
789
790
794
796
800
801
802
804
806
808
809
810
816
818
819
820
824
826
828
829
840
842
844
846
847
848
849
860
862
864
866
867
868
869
876
878
880
882
884
886
887
888
890
891
894
896
897
899
901
902
907
910
914
916
926
928
929
941
946
947
961
962
966
967
968
969
976
980
982
986
987
991
998

los números que me devolvería serian los siguientes:

407
467
470
476
479
487
647
704
746
748
749
764
784
794
847
947

Agradecería fuese una formula ya queen la hoja que estoy trabajando tengo muchas macros.
Microsoft Office Professional Plus 2010

wibly


Hola rguayabo,

En una frases dices: "tener en cuenta solo aquellos números que contengan los números 47 o 74", pero luego dices que el 407 contiene el número 47... expresemos mejor las ideas, ¿querés los que contengan ambos dígitos 4 y 7?... para esto te puede servir la función HALLAR.

Lee las normas para hacer consultas (ir a INDICE y ver arriba)... adjunta el archivo. 

Saludos

Adrián

Ver el tema anterior Ver el tema siguiente Volver arriba  Mensaje [Página 1 de 1.]

Permisos de este foro:
No puedes responder a temas en este foro.