UniversoExcelForo

Respuesta a consultas.
Fecha de creación: 09.Abril.2012

Fundadores: Wibly,Tyno,Servando,Sakkar,Rosendo2,RMaximo,Railar,Mcoronel,Ioyama,Igtelo,Hugotron,Drochar,Dedos,Alberto,Adolfo

No se pueden hacer consultas de Excel o VBA por mensaje privado.
Utiliza el botón buscar del foro y te ahorras tiempo para obtener "ayuda".

No estás conectado. Conéctate o registrate

Ver el tema anterior Ver el tema siguiente Ir abajo  Mensaje [Página 1 de 1.]

borboleta85


Hola gente,

Adjunto la condicional que he hice, que funciona como quiero excepto una parte que no se porque no me reconoce o hago algo que no esta bien.
Quiero hacer para la condicion FP que es cuando en la C1 aparece "fish" y en la C2 en blanco, lo especifico asi en la condicional pero en vez de FP me aparece "not fish" y no entiendo porque.
El resto de condiciones estan como quiero.

Si alguien puede ayudarme agradezco, gracias.

Un saludo
Archivos
FORO 23'.xlsx
No tienes los permisos para descargar los archivos.
(33 KB)

wibly


Hola borboleta85,

Ten cuidado al plantear estas formulas condicionales con varios SI anidados.

Tu fórmula inicia con =SI(B2<>"", y le sigue el resto de condiciones que serán válidas solo en el caso de que la celda B2 no esté vacía, por más que haya un SI que dice SI(B2=" ","FP",SI(A2="FISH ","FP"," ")).... porque como esto quedó metido dentro de la estructura del primer SI es una condición que no tienen sentido... es como plantear lo siguiente:
Si soy argentino, entonces si soy usuario de UniversoExcelForo entonces A4=5, si soy colombiano entonces A4=10 (pero esto es IMPOSIBLE si es que soy Argentino). Para resolvero hay que cerrar el SI soy argentino antes de arrancar con el SI soy colombiano... se entiende.

Por como tenés planteada la fórmula, lo único válido cuando la celda se encuentra vacía es: ," NOT FISH ")

Te recomiendo que cuando tengas muchas condiciones te hagas un esquema en papel de la estructura y al pasarlas a la fórmula en Excel las vayas cerrando cuendo corresponde.

Comenta si puedes resolverlo y si no vemos como seguimos... en este último caso para poder ayudarte necesetaríamos todas las condiciones a cumplir, definidas correctamente.

Saludos

Adrián

borboleta85


Hola,

Gracias por responder, ya entiendo lo que me dices.He cambiado la estructura y he arreglado los FP pero ahora no me sale con los FN.
La estructura que yo he planteado es:
Si la C1="FISH" y la c2=pesca atum sera TP (true +)
Si la c1=fish y la c2=" " sera FP (FALSE+)
Si la c2=pesca atum y la c1=steam, night o hbr(todas menos fish) sera FN (FALSE -)
y para el resto o que no ponga nada o que ponga not fish.Lo que no entiendo es porque me funciona con algunos datos y con otros no.

Gracias
Archivos
FORO 23'.xlsx
No tienes los permisos para descargar los archivos.
(32 KB)

wibly


Entiendo que está mal la estructura y creo que te estás complicando mucho al plantearla, se puede hacer más sencilla.

Según las tres condiciones que das (el realidad son 4, diciendo que para el resto ponga " ") y considerando ese orden te propongo esta fórmula:

=SI(Y(A2="FISH",B2="Pesca atum"),"TP",SI(Y(A2="FISH",B2=""),"FP",SI(Y(B2="Pesca atum",O(A2="Steam",A2="Nigth",A2="HBR")),"FN","")))

Saludos

Adrián

borboleta85


Hola,

Pues deberia de funcionar pero lo he probado en dos bases diferentes y en una (la que te adjunto) no me reconoce los FP (FISH=" "); y en la otra no me reconoce los FN y me los deja en blanco y no se porque.
Te adjunto el excel aver si tu ves el error.

Gracias
Archivos
FORO 23'.xlsx
No tienes los permisos para descargar los archivos.
(45 KB)

borboleta85


Ya consegui que funcionara en todas las bases menos una, osea que la formula era correcta ; porque no funcionaba ya lo descubrire.

Gracias por el tiempo, un saludo

wibly


Ok, me alegra que lo hayas resuelto!

Ver el tema anterior Ver el tema siguiente Volver arriba  Mensaje [Página 1 de 1.]

Permisos de este foro:
No puedes responder a temas en este foro.