UniversoExcelForo

Respuesta a consultas.
Fecha de creación: 09.Abril.2012

Fundadores: Wibly,Tyno,Servando,Sakkar,Rosendo2,RMaximo,Railar,Mcoronel,Ioyama,Igtelo,Hugotron,Drochar,Dedos,Alberto,Adolfo

No se pueden hacer consultas de Excel o VBA por mensaje privado.
Utiliza el botón buscar del foro y te ahorras tiempo para obtener "ayuda".

No estás conectado. Conéctate o registrate

Ver el tema anterior Ver el tema siguiente Ir abajo  Mensaje [Página 1 de 1.]

borboleta85


Hola gente,

Adjunto un ejemplo de lo que quiero hacer, la formula ya la sé pero no se que pasa o que hago mal que cuando arrastro la formula y llega a la fila 17 me da el error de value#. Lo que quiero calcular es la distancia a los puertos con las latitudes y longitudes de los puertos y con las latitudes y longitudes de los barcos.

He puesto solo una muestra pero si se arrastra es cuando da error en la 17, si alguien puede ayudarme agradeceria mucho.

Muchas gracias, un saludo
Archivos
ejemplo foro.xlsx
No tienes los permisos para descargar los archivos.
(10 KB)

wibly


Hola borboleta85,

Según lo que veo el error se produce porque no hay datos por debajo de la fila 17. Además en las columnas A y B hay 7 datos y en las G y H hay 17... puede ser que te convenga agregar una restricción de que el cálculo se realice solo si en las 4 columnas hay dato. Esto lo podés agregar con =SI(CONTAR(A2;B2;G2;H2)=4;[formula];"").
Y si querés que no se muestren los errores lo podés hacer con =SI.ERROR([formula];"").

Por otro lado ¿estás seguro que la fórmula? Las fórmulas utilizan las columnas H e I y no las columnas G y H.

Saludos

Adrián

borboleta85


Gracias por la respuesta , entiendo lo que me quieres decir de los rangos .Pero lo que yo quiero hacer es calcular a partir de las latitudes y longitudes de los barcos la distancia a esos puertos con las coordenadas de esos puertos, no puedo tener la misma cantidad de datos en las columnas porque las coordenadas de los puertos solo son esas, no se si me explico.Esta es la formula que he utilizado, no hay alguna manera de que la formula calcule las distancias entre las coordenadas respecto a las coordenadas de los puertos pero con un rango de filas que no es el mismo? porque de barcos igual tengo 500 coordenadas y de puertos 7, entonces no se como hacer.

Gracias, un saludo.

{=MIN((ACOS(SIN(RADIANS(H2))*SIN(RADIANS(Ports!C$2:C$16))+COS(RADIANS(H2))*COS(RADIANS(Ports!C$2:C$16))*COS(RADIANS(I2)-RADIANS(Ports!B$2:B$16)))*6371)/1.852)}
 
Em vez de ENTER tens que fazer CONTROL + ENTER
 
H2= Latitude do VMS
I2 = Longitude do VMS
Ports!C$2:C$16 = Latitude dos portos
Ports!B$2:B$16 = Longitude dos portos

wibly


Creo que la consulta no está bien planteada de entrada... ¿estás seguro que para las primeras 17 filas la distancia está bien calculada? Insisto con el tema de la fórmula porque no la veo bien, fijate que si cambias los valores de la columna G las distancias no cambian.

Por qué no la hacés más simple para ver donde tenés el error. Te propongo que para cada barco calcules la distancia a cada puerto en diferentes columnas y luego halles el mínimo en otra columna... es una sugerencia para que vallas viendo el funcionamiento. O sea que los datos de los puertos los tendrías en diferentes columnas y poniendo $ en las filas (para fijar las coordenadas de los puertos en las fórmulas) entiendo que no tendrías problemas al arrastrar.

De todos modos insisto en que para mí no está bien la fórmula.

Saludos

Adrián

borboleta85


Hola, 

Y a solucioné el problema, era una funcion matricial y tenia que dar control+shift+enter para que funcionara.

Gracias, un saludo

Ver el tema anterior Ver el tema siguiente Volver arriba  Mensaje [Página 1 de 1.]

Permisos de este foro:
No puedes responder a temas en este foro.