UniversoExcelForo

Respuesta a consultas.
Fecha de creación: 09.Abril.2012

Fundadores: Wibly,Tyno,Servando,Sakkar,Rosendo2,RMaximo,Railar,Mcoronel,Ioyama,Igtelo,Hugotron,Drochar,Dedos,Alberto,Adolfo

No se pueden hacer consultas de Excel o VBA por mensaje privado.
Utiliza el botón buscar del foro y te ahorras tiempo para obtener "ayuda".

No estás conectado. Conéctate o registrate

Ver el tema anterior Ver el tema siguiente Ir abajo  Mensaje [Página 1 de 1.]

1RESUELTO Cambio de formato de celdas el 05/03/14, 05:55 pm

wibly


Estimados, hoy me toca preguntar.

Tengo dos bases de datos 'grandes' (proveniente de fuente desconocida, me llega el Excel directamente) y resulta que un campo (ISBN#) en una tiene formato de TEXTO y en la otra formato ESPECIAL (código postal)... no me pregunte por qué Crying or Very sad .

El problema es que al utilizar la función BUSCARV, al buscar un valor de una de las tablas en la otra tabla me da error (por la diferencia de formatos). Para ejemplificar simplifico un poco los datos en el archivo que adjunto.

La pregunta es como pasar, por ejemplo toda la columna D (que puede tener 10.000 filas), a formato TEXTO y que funcione... porque si tenemos pocos datos le aplico formato TEXTO, me meto en cada una de las celdas y listo (como en columna G), pero si son muchas celdas no es práctico, y me queda como en columna J (formato TEXTO pero no funciona el BUSCARV).

Creo que se entiende la columna y también creo que alguna vez leí al respecto pero ahora no recuerdo cómo se hacía.

Saludos a todos

Adrián
Archivos
Consulta formatos.xls
No tienes los permisos para descargar los archivos.
(20 KB)



Última edición por wibly el 06/03/14, 06:43 pm, editado 1 vez (Razón : tema resuelto)

2RESUELTO Re: Cambio de formato de celdas el 05/03/14, 09:59 pm

tyno


Hola Adrian.

Probá de insertar esta formula matricial que detallo abajo, en la celda E2, que toma la referencia de D2 donde, según tu archivo hay un dato con formato codigo postal:

{=BUSCARV(D2;($A$2:$B$4)*1;2;0)}

O sea, lo único que tenes que hacer es multiplicar por 1 el rango de búsqueda, esto hace que los datos sean tomados como número, ya sean datos con formato texto, número, científico, cod postal, etc.

Desde luego la fórmula es =BUSCARV(D2;($A$2:$B$4)*1;2;0) y luego la seleccionas y convertís en matricial con shift+ctrl+enter.
Si esta fórmula te sirve la extendés al resto de las filas.

Saludos

3RESUELTO Re: Cambio de formato de celdas el 05/03/14, 10:12 pm

tyno


Otra cosa, lo que deberías después, una vez que tengas los resultados, es convertir las formulas en texto, porque creo que te va a quedar medio pesadito el archivo con miles de formulas matriciales.

4RESUELTO Re: Cambio de formato de celdas el 05/03/14, 10:53 pm

Igtelo


Hola Adrián / Tyno.

Yo aplico el método normal que describe Tyno de multiplicar por 1 y ya queda.

Como información, hay bases de datos que presentan a la vista "X" cantidad de caracteres y si aplicamos la fórmula de largo nos dan más; esto lo he visto sobre todo en las fechas, a la vista ves la fecha normal pero dentro tienen espacios en blanco lo puedes constatar con texto en columnas, obviamente cuando se presente el caso.

Un abrazo
Nacho Téllez

5RESUELTO Cambio de formato de celdas el 05/03/14, 11:54 pm

DEDOS


Hola, buenas noches:
Te envío una sugerencia, en tu archivo, espero te sirva, en lo personal me dio resultado.
Saludos y Suerte.
Archivos
Consulta formatos.xlsx
No tienes los permisos para descargar los archivos.
(101 KB)

6RESUELTO Re: Cambio de formato de celdas el 06/03/14, 08:21 am

wibly


Gracias por todas las respuestas.

Estoy entre la propuesta de Tyno, actuando sobre el BUSCARV o bien trabajar directamente sobre la base de datos.

Gracias!

Adrián

Ver el tema anterior Ver el tema siguiente Volver arriba  Mensaje [Página 1 de 1.]

Permisos de este foro:
No puedes responder a temas en este foro.