UniversoExcelForo

Respuesta a consultas.
Fecha de creación: 09.Abril.2012

Fundadores: Wibly,Tyno,Servando,Sakkar,Rosendo2,RMaximo,Railar,Mcoronel,Ioyama,Igtelo,Hugotron,Drochar,Dedos,Alberto,Adolfo

No se pueden hacer consultas de Excel o VBA por mensaje privado.
Utiliza el botón buscar del foro y te ahorras tiempo para obtener "ayuda".

No estás conectado. Conéctate o registrate

Ver el tema anterior Ver el tema siguiente Ir abajo  Mensaje [Página 1 de 1.]

1RESUELTO Macro control por referencia el 14/01/14, 02:42 am

Invitado


Invitado
Buenos días, necesito una macro, no se como empezar hacerla.
En la hoja "Listado" columna "B" "REFERENCIAS", que sume todas las filas por referencias de la columna "L" "CANTIDAD".
Y me las grabe en la hoja "ControlArticulos" y que me la grabe en la fila de dicha referencia en la columna "D" "CANTIDAD".
Gracias.
Archivos
EJEMP.xls
(17 KB)

2RESUELTO Re: Macro control por referencia el 14/01/14, 11:51 am

SAKKAR


Luishc, cómo estás?

Realmente este NO ES UN PROBLEMA para ser resuelto por macros, ya que tiene NATIVAMENTE EN ECXEL, una función que cubre tu necesidad. La misma es sumar.si.conjunto
=SUMAR.SI.CONJUNTO(Listado!$L$4:$L$22;Listado!$B$4:$B$22;B4)

Esto lo aplique a tu hoja y resuelve el problema...

PEDIDO AL ADMIN para mover este hilo a FORMULAS


Espero te sirva!!
y si lo ha hecho
Recuerda dar unas gracias y cerrar el tema como resuelto...  nos hace muyyyyy felices


Salutte
Archivos
Solucion.xlsx
No tienes los permisos para descargar los archivos.
(12 KB)

3RESUELTO Re: Macro control por referencia el 14/01/14, 12:52 pm

Invitado


Invitado
A mi no me sale, lo que me sale es:
#¿NOMBRE?

no me sale la cantidad- Gracias de todas formas

4RESUELTO Re: Macro control por referencia el 14/01/14, 12:55 pm

SAKKAR


Será porque tenes otra version de excel???

Que excel tenes??

5RESUELTO Re: Macro control por referencia el 14/01/14, 12:57 pm

Invitado


Invitado
2003
y dime donde esta el me gusta
gracias

6RESUELTO Re: Macro control por referencia el 14/01/14, 02:29 pm

SAKKAR


mmmm ahi podría estar el problema....

Fijate si lo podes resolver adaptando la formula de sumar.si

avisame

7RESUELTO Re: Macro control por referencia el 14/01/14, 02:49 pm

Invitado


Invitado
Lo he hecho en la formula me sale debajo 48, pero cuando le doy a aceptar en vez de salir 48, en la misma celda y arriba en la formula me sale:

=SUMAR.SI(Listado!B4:B22;"B";Listado!L4:L22)

Y dime donde pincho para Me gusta
Gracias

8RESUELTO Re: Macro control por referencia el 14/01/14, 03:03 pm

SAKKAR


jajaja no se que es el boton me gusta....  perdon

No comprendí muy bien que pasa arriba o abajo...  pero en principio proba "frizando" las celdas de referencia:se colocan signos $ entre las referencias a las celdas

=SUMAR.SI(Listado!$B$4:$B$22;"B";Listado!$L$4:$L$22)

9RESUELTO Re: Macro control por referencia el 14/01/14, 03:09 pm

Invitado


Invitado
Me sale igual

10RESUELTO Re: Macro control por referencia el 14/01/14, 03:16 pm

SAKKAR


Subi el archivo nuevo por favor y veremos que pasa

11RESUELTO Re: Macro control por referencia el 14/01/14, 04:21 pm

Invitado


Invitado
Lo hice en un libro nuevo, y me salio perfecto, agregue unas copias a mi libro, cambie los datos y perfecto.
No tengo ni idea, pero ha salido, le hice todo tipo de pruebas y funciona a la perfecion.
Muchísimas gracias.

Ver el tema anterior Ver el tema siguiente Volver arriba  Mensaje [Página 1 de 1.]

Permisos de este foro:
No puedes responder a temas en este foro.