UniversoExcelForo

Respuesta a consultas.
Fecha de creación: 09.Abril.2012

Fundadores: Wibly,Tyno,Servando,Sakkar,Rosendo2,RMaximo,Railar,Mcoronel,Ioyama,Igtelo,Hugotron,Drochar,Dedos,Alberto,Adolfo

No se pueden hacer consultas de Excel o VBA por mensaje privado.
Utiliza el botón buscar del foro y te ahorras tiempo para obtener "ayuda".

No estás conectado. Conéctate o registrate

Ver el tema anterior Ver el tema siguiente Ir abajo  Mensaje [Página 1 de 1.]

1RESUELTO CONSULTAV() con doble condición el 17/04/12, 07:00 pm

mcoronel


Hola a todos,
Por favor su ayuda con el problema planteado en el archivo adjunto.
Consiste en encontrar un dato validando dos entradas

Saludos
Marco bounce bounce
Archivos
a1.xlsx
No tienes los permisos para descargar los archivos.
(10 KB)

2RESUELTO UTILIZA SUMAPRODUCTO el 17/04/12, 11:06 pm

railar


Hola, Marco

Ya Adrián hizo el planteamiento sobre que más conviene,
con SUMAPRODUCTO lo puedes lograr

Saludos,

Raúl
Archivos
a1.xlsx
No tienes los permisos para descargar los archivos.
(10 KB)

3RESUELTO Re: CONSULTAV() con doble condición el 18/04/12, 04:56 am

ioyama


Hola mcoronel (y railar)

Adjunto otra opción, usando funciones matriciales (recuerdo, usar Control+Mayúsculas+Intro en vez de sólo Intro) que hace la misma operación, pero que además permite obtener valores alfanuméricos (con SUMAPRODUCTO sólo se pueden obtener valores numéricos).

Un saludo desde Vitoria

Edito: No me entra el adjunto (ocupa muy poquito, pero...), no obstante la función usada sería

=INDICE(Hoja2!$C$3:$C$11;COINCIDIR(Hoja1!A3&Hoja1!B3;Hoja2!$A$3:$A$11&Hoja2!$B$3:$B$11;0))

introducida matricialmente.

4RESUELTO Re: CONSULTAV() con doble condición el 18/04/12, 09:58 am

mcoronel


Gracias por su ayuda, lo de SUMAPRODUCTO() no logro definir cual es la logica de ejecucion por favor si me ayudan con eso y lo de las matrices pues..... igual, aunque las dos he podido aplicarlas a lo que necesito. por favor si me dan una esplicadita de como funcionan.

una ves mas gracias

Saludos
Marco

5RESUELTO Re: CONSULTAV() con doble condición el 18/04/12, 10:33 am

mcoronel


Hola ioyama mil gracias por tu ayuda, estoy teniendo problemas al aplicar la formula, mejor dicho una ves aplicada la formula pues se modifica ampliando el ancho de columna y no puedo reducirlo a que se puede dever este particular??

Saludos
Marco

6RESUELTO Re: CONSULTAV() con doble condición el 18/04/12, 11:08 am

ioyama


Hola Marco

Acabo de ver tu segunda pregunta mientras preparaba respuesta para la anterior, así que iré por partes.

SUMAPRODUCTO, te comento unas pequeñas nociones sobre su uso, supongamos que tenemos

X A B C
1 1 3 a
2 2 4 b
3 2 1 a



es decir 3 filas y 3 columnas, veamos algunos ejemplos

Ejemplo 1 (como operador)
=SUMAPRODUCTO((A1:A3)*(B1:B3)) es equivalente a = (1*3)+(2*4)+(2*1) = 3+8+2 = 13, es decir ejecuta la suma de los productos de las matrices seleccionadas (por ello es importante que el dimensionamiento de las matrices sea el mismo, en este caso ambas son de tres elementos.

Ejemplo 2 (contar según condiciones), por ejemplo, ¿cuántos elemento cumplen que el valor de la columna A sea un 2 y el de la C una b?
=SUMAPRODUCTO((A1:A3=2)*(C1:C3=”b”)) es equivalente a = ((FALSO*FALSO) + (VERDADERO*VERDADERO) + (VERDADERO*FALSO)) = 0 + 1 + 0 = 1

((FALSO*FALSO) + (VERDADERO*VERDADERO) + (FALSO*FALSO)) esto se obtiene de
1=2*a=b + 2=2*b=b + 2=1*a=b, según las condiciones especificadas

Ejemplo 3 (operar con condiciones) , por ejemplo, ¿cuánto suman los elementos de la columna B cuyos valores de la columna A sea un 2 y de la C una b?
la columna A sea un 2 y el de la C una b?
=SUMAPRODUCTO((A1:A3=2)*(C1:C3=”b”)*(B1:B3)) es equivalente a = ((FALSO*FALSO*3) + (VERDADERO*VERDADERO*4) + (VERDADERO*FALSO*1)) = 0 + 4 + 0 = 4

Ejemplo 4 (criterios de comparación)
=SUMAPRODUCTO((A1:A3=2)) = 0
Devuelve FALSO + VERDADERO + VERDADERO, no operable por lo que da 0
=SUMAPRODUCTO((A1:A3=2)*1) = 2
Al multiplicar por cada término de la matriz devuelve 0 + 1 + 1 = 2
=SUMAPRODUCTO(--(A1:A3=2))=2
El doble signo negativo trnasforma FALSO en 0 y VERDADERO en 1, luego 0 + 1 + 1 = 2
=SUMAPRODUCTO(N(A1:A3=2))
Produciría este mismo efecto

Espero que te sirva para aclarate un poquito más.

Pasaré a la matricial y a tu otra pregunta mo sé si en un rato o ya a la noche dependerá de las circunstancias.

Un saludo desde Vitoria

7RESUELTO Re: CONSULTAV() con doble condición el 18/04/12, 01:56 pm

mcoronel


Gracias por la explicación, esta bien didactica, por la otra consulta estare al pendiente de tu respuesta

Saludos
Marco

8RESUELTO Re: CONSULTAV() con doble condición el 18/04/12, 02:53 pm

ioyama


Hola Marco

No acabo de entender a qué te refieres cuando dices

"...estoy teniendo problemas al aplicar la formula, mejor dicho una ves aplicada la formula pues se modifica ampliando el ancho de columna y no puedo reducirlo..."

Creo que te refieres al formato, pero es algo que no consigo reproducir por lo que no puedo darte ninguna solución.

Respecto a la función matricial no deja de ser una combinación de INDICE y COINCIDIR con la particularidad de concatenar dos columnas en la función COINCIDIR, tanto para el témino de búsqueda como para la matriz en la que buscar. AL introducir matricialmente la función se consigue que se devuelva el valor correcto ya que a todos los efectos busca un valor en una única matriz (columna en este caso).

Un saludo desde Vitoria

P.S. Si consigues solucionar el problema del ancho comenta cómo lo has hecho (por curiosidad)

9RESUELTO Re: CONSULTAV() con doble condición el 18/04/12, 06:49 pm

mcoronel


Hola ioyama,
Gracias por tiempo y ayuda, en lo que respecta al problema en el formato de celda este solo se presenta cuando copio la formula desde el foro al archivo pero si digito no se presenta el problema, debo estar cometiendo algun error o almenos eso creo.
Con lo de las formulas creo que me tomara un tiempo el poder dominarlas pero estoy en camino.

Saludos
Marco

10RESUELTO Re: CONSULTAV() con doble condición el 19/04/12, 06:54 am

wibly


Hola Marco,

No se si será este el caso pero por las dudas comento que al copiar una fórmula desde fuera de Excel puede no funcionar por tener definido diferente separador de los parámetros de las fórmulas. Por ejemplo en lo que aporta ioyama el separador es ";" y alguien puede tener definido ",", por lo que no funcionaría y solo bastar con reemplazar las ";" por ",".

Saludos

Adrián Wibly

11RESUELTO Re: CONSULTAV() con doble condición el 19/04/12, 12:24 pm

mcoronel


Hola Adrian, gracias por revisar mi consulta,
No es ese el caso lo que sucede es que al momento de copiar la formula el ancho de columna varia y me queda demasiada ancha y sin poderla modificar para reducir el ancho

Saludos
Marco

Con respecto a la formula en si, esta funcionando perfectamente

Ver el tema anterior Ver el tema siguiente Volver arriba  Mensaje [Página 1 de 1.]

Permisos de este foro:
No puedes responder a temas en este foro.