UniversoExcelForo

Respuesta a consultas.
Fecha de creación: 09.Abril.2012

Fundadores: Wibly,Tyno,Servando,Sakkar,Rosendo2,RMaximo,Railar,Mcoronel,Ioyama,Igtelo,Hugotron,Drochar,Dedos,Alberto,Adolfo

No se pueden hacer consultas de Excel o VBA por mensaje privado.
Utiliza el botón buscar del foro y te ahorras tiempo para obtener "ayuda".

No estás conectado. Conéctate o registrate

Ver el tema anterior Ver el tema siguiente Ir abajo  Mensaje [Página 1 de 1.]

1RESUELTO Problema con fórmula de excel el 01/12/13, 08:02 pm

azevrec


Hola amigos:
 Esto es lo que pretendo hacer,y que me está costando bastante trabajo:

Quiero que respecto a 5 números-de valor entre el 1 y el 50- que introduzco en las casillas B4 a F4,me sume el valor de los dígitos separadamente de cada casilla y me de el valor final.
Me explico:

5+(13)+(24)+(29)+(42),a su vez,sumaríamos los dígitos dobles y nos quedaría:

5 + 4 + 6+ 11 + 6.Pero como el 11 tiene 2 dígitos,también quiero que sume el 11(1+1),y  se convierta en 2.

La suma final sería de:

5 + 4 + 6+ 2 + 6=23.

Un buen amigo me ha facilitado la fórmula que lo hace,pero no me funciona,pues me da un problema con la cifra 1,9,que me la resalta, y me dice que cual es el divisor:

=SUMPRODUCT(1+MOD(SUM(B4)-1;9))+SUMPRODUCT(1+MOD(SUM(C4)-1;9))+SUMPRODUCT(1+MOD(SUM(D4)-1;9))+SUMPRODUCT(1+MOD(SUM(E4)-1;9))+SUMPRODUCT(1+MOD(SUM(F4)-1;9))

¿alguna ayuda de por qué no me funciona la fórmula?.Tengo el excel 2007.

He probado también en español y tampoco me funciona:

=SUMAPRODUCTO(1+RESIDUO(SUMA(B4)-1,9))+SUMAPRODUCTO(1+RESIDUO(SUMA(C4)-1,9))+SUMAPRODUCTO(1+RESIDUO(SUMA(D4)-1,9))+SUMAPRODUCTO(1+RESIDUO(SUMA(E4)-1,9))+SUMAPRODUCTO(1+RESIDUO(SUMA(F4)-1,9))


Si alguien me puede ayudar,o proporcionarme otra fórmula alternativa que lo haga, gracias por anticipado.Very Happy

2RESUELTO Problema con fórmula de excel el 01/12/13, 10:05 pm

railar


Hola azevrec,
Prueba con esta formulita
Código:
=SI(Y(LARGO(SI(RESIDUO(B$4;1)<1;SUMAPRODUCTO(EXTRAE(SUSTITUIR(B$4;",";0);FILA(INDIRECTO("1:"&LARGO(SUSTITUIR(B$4;",";0))));1)*1);SUMAPRODUCTO(EXTRAE(B$4;FILA(INDIRECTO("1:"&LARGO(B$4)));1)*1)))>1;SI(RESIDUO(B$4;1)<1;SUMAPRODUCTO(EXTRAE(SUSTITUIR(B$4;",";0);FILA(INDIRECTO("1:"&LARGO(SUSTITUIR(B$4;",";0))));1)*1);SUMAPRODUCTO(EXTRAE(B$4;FILA(INDIRECTO("1:"&LARGO(B$4)));1)*1))>9);SUMAPRODUCTO(EXTRAE(SI(RESIDUO(B$4;1)<1;SUMAPRODUCTO(EXTRAE(SUSTITUIR(B$4;",";0);FILA(INDIRECTO("1:"&LARGO(SUSTITUIR(B$4;",";0))));1)*1);SUMAPRODUCTO(EXTRAE(B$4;FILA(INDIRECTO("1:"&LARGO(B$4)));1)*1));FILA(INDIRECTO("1:"&LARGO(SI(RESIDUO(B$4;1)<1;SUMAPRODUCTO(EXTRAE(SUSTITUIR(B$4;",";0);FILA(INDIRECTO("1:"&LARGO(SUSTITUIR(B$4;",";0))));1)*1);SUMAPRODUCTO(EXTRAE(B$4;FILA(INDIRECTO("1:"&LARGO(B$4)));1)*1)))));1)*1);SI(RESIDUO(B$4;1)<1;SUMAPRODUCTO(EXTRAE(SUSTITUIR(B$4;",";0);FILA(INDIRECTO("1:"&LARGO(SUSTITUIR(B$4;",";0))));1)*1);SUMAPRODUCTO(EXTRAE(B$4;FILA(INDIRECTO("1:"&LARGO(B$4)));1)*1)))
Saludos

PD: Te paso una muestra
Archivos
Sumatoria de los digitos de un número.xlsx
No tienes los permisos para descargar los archivos.
(9 KB)



Última edición por railar el 01/12/13, 10:13 pm, editado 1 vez (Razón : Subir Archivo)

azevrec


Hola railar:

Lo primero muchísimas gracias por tu enorme interés haciendo esa gran fórmula.

Lo único que veo de problema es que esa fórmula creo que sólo me suma lo que hay en la casilla B4,,y yo lo que quiero es que me sume en horizontal,por ejemplo en la casilla AA,las sumas de los resultados de las casillas B4,C4,D4,E4 yF4.

Imagino que tendré que modificar tu fórmula 5 veces para que me sume el contenido de las 5 casillas de la B a la F,y luego decirle que las sume todas en la casilla que la coloque,¿no?.

No se si sabré crear la suma total,de las 5 subsumas...

De todas formas,muchas gracias por tu respuesta,pues es de agradecer.

Saludos.Smile

4RESUELTO Problema con fórmula de excel el 01/12/13, 11:00 pm

railar


azevrec, 

ya revisaste el archivo, solo tienes que correr la formula horizontalmente y luego aplicarle una sumatoria al rango

Saludos

5RESUELTO Problema con fórmula de excel el 01/12/13, 11:29 pm

railar


Te paso nuevamente el archivo con formulas y con otra solución a través de una UDF (Para la cual debes activar las macros cuando te lo solicite)

Saludos
Archivos
Sumatoria de los digitos de un número2.xlsm
No tienes los permisos para descargar los archivos.
(16 KB)

Igtelo


Hola azevrec / Raúl.

Te paso otra alternativa con columnas auxiliares, hace 2 separaciones; la ventaja es que no usamos fórmula larga y las que aplicamos son sencillas.

Saludos
Ignacio Téllez
Archivos
digitos.xlsx
No tienes los permisos para descargar los archivos.
(21 KB)

azevrec


Muchísimas gracias railar e igtelo.En estos momentos no puedo probar la fórmula,pero cuando tenga un momento las pruebo.

Gracias de nuevo.Very Happy 

P.D.Por cierto,Igtelo,mi nombre no es Raul.

ioyama


Hola azevrec (Raúl e Ignacio)

No he podido resistirme y.... con una función matricial..... pues eso. Otra opción más.

Azevrec te recuerdo que hay que usar Mayúsculas+Control+Intro para introducir la función matricialmente.

Un saludo desde Vitoria
Archivos
SumarDigitos_igtelo_io_131202.xlsx
No tienes los permisos para descargar los archivos.
(13 KB)

azevrec


Hola amigos:

railar,Igtelo,e ioyama.Lo primero muchísimas gracias de nuevo por vuestra ayuda.

Habéis sido muy rápidos en darme ayuda y os lo agradezco mucho.

La fórmula funciona perfectamente,aunque he usado la más corta sólo por motivos de trabajar más cómodamente,pero os doy las gracias a los tres.

Un saludo,y que tengáis felices fiestas navideñas.

Hasta pronto
cheers

10RESUELTO Re: Problema con fórmula de excel el 02/12/13, 06:01 pm

Igtelo


Saludos a todos!!!

Estos posts son lo que me encantan!!! 4 formas distintas de encontrar solución.

Muuuuuchísimas gracias compañeros!! Así más aprendo.

Nacho Téllez
P.d: Le pongo el ícono de resuelto.

11RESUELTO Re: Problema con fórmula de excel el 02/12/13, 06:12 pm

azevrec


Hola:

Me alegro mucho de que además de ayudar a alguien lo paseis bien.

Sois geniales.Very Happy

12RESUELTO Re: Problema con fórmula de excel el 04/12/13, 11:18 am

wibly


me sumo al comentario de Nacho... saludos!

Ver el tema anterior Ver el tema siguiente Volver arriba  Mensaje [Página 1 de 1.]

Permisos de este foro:
No puedes responder a temas en este foro.