UniversoExcelForo

Respuesta a consultas.
Fecha de creación: 09.Abril.2012

Fundadores: Wibly,Tyno,Servando,Sakkar,Rosendo2,RMaximo,Railar,Mcoronel,Ioyama,Igtelo,Hugotron,Drochar,Dedos,Alberto,Adolfo

No se pueden hacer consultas de Excel o VBA por mensaje privado.
Utiliza el botón buscar del foro y te ahorras tiempo para obtener "ayuda".

No estás conectado. Conéctate o registrate

Ver el tema anterior Ver el tema siguiente Ir abajo  Mensaje [Página 1 de 1.]

tyno


Hola amigos del foro.
Quiero compartir un archivo que contiene unos ejemplos con una fórmula para SUMAR columnas salteadas o intervalos de columnas.

La formula para Excel 2010 queda expresada de esta manera:

Código:
=SUMAPRODUCTO((RESTO(COLUMNA(rango);numero_intervalo)=INDICE(RESTO(COLUMNA(rango);numero_intervalo);;1))*rango)
En Excel 2010 (SP1), 2007 o 2003 la función RESTO cambia por RESIDUO .

Expresada como matricial:

Código:
{=SUMA((RESIDUO(COLUMNA(rango);numero_intervalo)=INDICE(RESIDUO(COLUMNA(rango);numero_intervalo);;1))*rango)}
Esta formula matricial desde luego sirve para Excel 2007 y también para Excel 2010 solo que hay que cambiar RESIDUO por RESTO.

En realidad esta formula se encuentra publicada en diversos lugares de la Web en sitios dedicados a Excel de esta manera por ejemplo:


=SUMAPRODUCTO((RESTO(COLUMNA(B4:R4);4)=2)*B4:R4)
Ese valor 2  en (RESTO(COLUMNA(B4:R4);4)=2), lo que hace es indicar dentro de la matriz RESTO(COLUMNA(B4:R4);4),  cual es la posición de la primer columna que necesitamos sumar.
Resulta que este valor 2 es relativo dependiendo de la ubicación de la primer columna del rango donde deseamos sumar las columnas salteadas.
Aclaro que no me voy a extender por que motivo este valor es relativo, por que es todo un tema a parte, relacionado con la función RESTO o RESIDUO en su forma matricial.
En un archivo que estuve realizando a la hora de aplicar la formula de esta manera se me presento el problema de saber cual era ese valor relativo en cuestión  por lo que probando aquí y allá encontré que con la formula: INDICE(RESIDUO(COLUMNA(rango);numero_intervalo);;1), se puede obtener el valor relativo de manera automática.

Todo esto se puede aplicar tanto para sumar como contar columnas o filas salteadas lo cual intento mostrar en el archivo que subo.

Entonces la idea de publicar esto es que, a parte de que la formula para sumar/contar columnas/filas salteadas este disponible esta formula en el foro, también contar con esta  adaptación que hice para obtener el valor de referencia de forma automática.



Nota:
Este archivo esta como Excel 2003 pero el ejemplo lo hice en base a Excel 2010 por lo que la formula del ejemplo puede dar error dependiendo la versión de Excel con que se abra. Sea como sea dentro del archivo he redactado la formula como sería para las diversas versiones Excel, entonces sería cuestión de copiar la formula que corresponde a nuestra versión y pegarla en la celda de "resultado" del ejemplo, teniendo en cuenta que quizás hay que re ingresar el signo = para que sean reconocidas las formulas y en el caso de las matriciales hay que quitar las llaves {} e ingresarlas seleccionado la formula y oprimir simultáneamente SHIFT+CONTROL+ENTER.

Saludos.
Archivos
sumar columnas filas salteadas.zip
No tienes los permisos para descargar los archivos.
(6 KB)



Última edición por tyno el 05/12/13, 05:16 pm, editado 4 veces

wibly


Muy bueno Tyno, saludos!

tyno


Hola Adrian.
Quiero agregar un caso mas que no contemple al principio y es la posibilidad de que las columnas intermedias a las que deseamos sumar/contar contengan texto en lugar de valores numéricos. Para esto, tomando el rango de ejemplo del archivo que he subido, habría que usar esta formula matricial:

Código:
{=SUMA((RESIDUO(SI(ESTEXTO(COLUMNA(A2:Q2)),0,COLUMNA(A2:Q2)),4)=INDICE(RESIDUO(SI(ESTEXTO(COLUMNA(A2:Q2)),0,COLUMNA(A2:Q2)),4),,1))*SI(ESTEXTO(A2:Q2),0,A2:Q2))}
En caso de copiarla hay que quitar las llaves y seleccionando la formula oprimir SHIFT+CONTROL+ENTER.
También hay que tener en cuenta el cambiar la coma por el punto y coma dependiendo como este configurado nuestro Excel.

Saludos

railar


Hola Tyno, Adrian

Interesante lo de hallar el valor de la columna o de la fila inicial,
muy bueno.

Un Abrazo

Ver el tema anterior Ver el tema siguiente Volver arriba  Mensaje [Página 1 de 1.]

Permisos de este foro:
No puedes responder a temas en este foro.