UniversoExcelForo

Respuesta a consultas.
Fecha de creación: 09.Abril.2012

Fundadores: Wibly,Tyno,Servando,Sakkar,Rosendo2,RMaximo,Railar,Mcoronel,Ioyama,Igtelo,Hugotron,Drochar,Dedos,Alberto,Adolfo

No se pueden hacer consultas de Excel o VBA por mensaje privado.
Utiliza el botón buscar del foro y te ahorras tiempo para obtener "ayuda".

No estás conectado. Conéctate o registrate

Ver el tema anterior Ver el tema siguiente Ir abajo  Mensaje [Página 1 de 1.]

ALDOCL


Hola desde Chile. 
Me estoy cabeceando con una función que me indique si hay coincidencias en todas las celdas A4 de un libro con 7 paginas.. La coincidencia debe ser validada solo para esta celda. De que forma establezco los criterios para que en forma horizontal me revise las 7 paginas celda por celda y sus equivalentes en las distintas hojas.  Estoy realizando una evaluación de proveedores de Flete, en la que la todas  las plantillas fueron completas por los distintos participantes y me entregan su oferta en un documento que contiene los mismos registros y el valor de servicio para cada uno de ellos, en los que eventualmente pudieran coincidir 2 o 3 o mas.

Ojala puedas ayudarme
Saludos

railar


Hola ALDOCL,

Bienvenido al foro, 

Para que cualquiera de los miembros del foro pueda brindarte una alternativa adecuada que puedas emplear en la solución que pretendes, es necesario que subas un archivo de muestra (no el original, para no comprometer tu confidencialidad), en el explicas y colocas los resultados esperados para mayor comprensión de tu necesidad

Saludos,

Raúl

ALDOCL


Aca les adjunto un archivo con parte del libro que estoy trabajando, obviamente tiene muchas mas columnas, asi que solo envio un estracto de las primeras para poder explicarles lo que estoy buscando (y hasta ahora no he encontrato)

Un saludo 

Aldocl
Archivos
AR.xlsx
Ojalá puedan ayudarme.
No tienes los permisos para descargar los archivos.
(55 KB)

railar


Hola ALDOCL,

Por lo pronto se me ocurre, para evitar la multiple anidación de la función SI, que haría super extensa la formula, colocar columnas auxiliares en donde se recogen los resultados de las hojas con embalaje mínimo, y con una UDF se concatenan los resultados.

Estas columnas auxiliares puedes ocultarlas,

Así mismo te recorté la formula con la que buscas el mínimo por una que funciona en 3D
=MIN('ar1:ar5'!C4)

Saludos, Raúl
Archivos
AR.xlsm
No tienes los permisos para descargar los archivos.
(63 KB)



Última edición por railar el 27/11/13, 11:28 pm, editado 2 veces

ALDOCL


Gracias  Raúl.. me parece excelente. Salvo que hice un cambio en la celda A1 y me arrojó un error de #nombre. Revisaré si aplicando en mi planilla original me da los resultados esperados. Pero de todas formas me queda claro. Mil gracias por el aporte... Por ahora dejare abierto el Post hasta mañana.

railar


ALDOCL,

Probé el archivo cambiando en A1 y me tomó el nuevo texto sin problemas,

Saludos nuevamente

Igtelo


Hola ALDOCL / Raúl.

Bajé el archivo de Raúl, hice cambios y funciona bien.

Saludos
Ignacio Téllez

ALDOCL


Hola, acabo de aplicar la función pero me sigue apareciendo el error #¿Nombre?
Podrá ser problema con la versión? Estoy con Office 2007

ALDOCL


Aca los datos de version
Archivos
VERSION OFFICE XLS.JPG
Aca los datos de version
No tienes los permisos para descargar los archivos.
(15 KB)

railar


Hola ALDOCL,

El  archivo lo trabajo con Excel 2007 y con extensión xls y funciona bien,

Te hago una pregunta, ¿al abrir el archivo habilitas las macros?

Recuerda que tiene una función (UDF) personalizada

Saludos

Igtelo


Hola ALDO / Raúl.

La versión no tiene nada que ver, los 3 lo hemos trabajado con Excel 2007, lo que te está pasando es que no estás escribiendo correctamente el nombre de la función o fórmula; te pongo un ejemplo del porque te aparece lo de #¿NOMBRE?

Supongamos que en una celda vas a efectuar una suma y la fórmula que usas sería ésta:

= SUMA(A1+B1)  Aquí funciona bien, ah pero si escribes:

= SOMA(A1+B1)  Te aparece #¿NOMBRE?, es solamente un error de dedo.

Fijate bien en el archivo que te dió Raúl y te sugiero que te ayudes con el ratón para evitar el error de dedo en la UDF.


Saludos
Ignacio Téllez

Ver el tema anterior Ver el tema siguiente Volver arriba  Mensaje [Página 1 de 1.]

Permisos de este foro:
No puedes responder a temas en este foro.