UniversoExcelForo

Respuesta a consultas.
Fecha de creación: 09.Abril.2012

Fundadores: Wibly,Tyno,Servando,Sakkar,Rosendo2,RMaximo,Railar,Mcoronel,Ioyama,Igtelo,Hugotron,Drochar,Dedos,Alberto,Adolfo

No se pueden hacer consultas de Excel o VBA por mensaje privado.
Utiliza el botón buscar del foro y te ahorras tiempo para obtener "ayuda".

No estás conectado. Conéctate o registrate

Ver el tema anterior Ver el tema siguiente Ir abajo  Mensaje [Página 1 de 1.]

Aretradeser


Utilizando la función DESREF, quiero calcular el promedio de DATOS1, DATOS2, DATOS3 y DATOS4, dependiendo del valor de la celda "A1" (que equivaldría al número de meses para los que quiero calcular el PROMEDIO; si el valor es 1, sería el promedio de enero; si el valor fuese 2, sería el promedio para enero y febrero y, así, sucesivemente). El problema me surge que cuando aplico la función DESREF, no me discrimina la Zona, toma como datos los reflejados en las tres Zonas de ese mes.
Ejemplo: si aplico a la celda "X12" la fórmula "=PROMEDIO(DESREF($B$2;1;0;1;$A$1))", me calcula el promedio de la suma de las celdas "B3", "C3" Y "D3" (ENE-ZONA1, ZONA2 y ZONA3); cuando, en realidad, quiero que calcule el promedio la suma de las celdas "B3", "E3" y "H3" (ENE-ZONA1; FEB-ZONA1 Y MAR-ZONA1)
Adjunto archivo de ejemplo.
Muchas gracias.
Saludos.
Archivos
DESREF_Foro.xls
No tienes los permisos para descargar los archivos.
(46 KB)

tyno


Hola Aretradeser.
Ta paso el archivo con una formula matricial que quizás te sirva.
En este caso la formula considera todos los casos para la ZONA1 y desde luego el rango que le indiquemos en A1. 
{=PROMEDIO(SI(DESREF($B$1;1;0;1;$A$1*3)="ZONA1";DESREF(B2;1;0;1;$A$1*3)))}

Si se quiere evaluar la ZONA2 o ZONA3 es cuestión de cambiar el criterio. Quizás se pueda agregar en A2 la zona y en la formula hacer referencia a A2 en lugar esta ingresando la zona, esto nos permitiria  ir evaluando los distintos resultados con solo cambiar los datos de A1 y A2.
{=PROMEDIO(SI(DESREF($B$1;1;0;1;$A$1*3)=A2;DESREF(B2;1;0;1;$A$1*3)))}

Recuerda que si modificas la formula matricial luego tienes que seleccionarla y  hacer shift+ctrl+enter . Saludos
Archivos
DESREF_Foro.xls
No tienes los permisos para descargar los archivos.
(40 KB)

railar


Hola Aretradeser, Tyno (Un Abrazo)

Otra alternativa sería con la función PROMEDIO.SI, siempre y cuando utilice Excel 2007 o superior.

Saludos

Raul
Archivos
DESREF_Foro (2).xls
No tienes los permisos para descargar los archivos.
(39 KB)

Aretradeser


tino, he adaptado tu función haciendo referencias a tres celdas que contiene los nombres de ZONA1, ZONA2 y ZONA3 (en tu archivo A11, A12 y A13); y, así, no tengo que ir cambiando la zona. Ahora que esto está solucionado, me gustaría, si es posible, perfeccionar un poco más el cálculo. La función actual, toma el valor de la celda "A1", para calcular el promedio de los meses; es decir, si ponemos "1", calcula el de enero, para la zona elegida; si "2", calcula el promedio de enero y febrero; y, asi sucesivamente. Ahora bien, imaginemos que queremos calcular el promedio de marzo a mayo, que modificación habría que realizar a esa función para conseguir este cálculo. Podríamos utilizar la celda "A1" para el mes de inicio del cálculo y la "A2" para el mes final? (Ejemp.: A1=3, sería marzo; y A2=5, se correspondería con mayo):
Muchas gracias tino y railar por vuestro esfuerzo y amabilidad en ayudarme.
Saludos

tyno


Hola Aretradeser.
Te paso el archivo con la modificación de la formula a ver si te sirve, creo te vas a dar cuenta que referencia he modificado. Entonces en A1 se ingresa el mes inicial a evaluar y en A2 la cantidad de meses hacia adelante o despus del mes inicial a evaluar. Saludos

https://www.dropbox.com/s/g2y7hs4lvl4yqcl/DESREF_Foro.zip

Ver el tema anterior Ver el tema siguiente Volver arriba  Mensaje [Página 1 de 1.]

Permisos de este foro:
No puedes responder a temas en este foro.