UniversoExcelForo

Respuesta a consultas.
Fecha de creación: 09.Abril.2012

Fundadores: Wibly,Tyno,Servando,Sakkar,Rosendo2,RMaximo,Railar,Mcoronel,Ioyama,Igtelo,Hugotron,Drochar,Dedos,Alberto,Adolfo

No se pueden hacer consultas de Excel o VBA por mensaje privado.
Utiliza el botón buscar del foro y te ahorras tiempo para obtener "ayuda".

No estás conectado. Conéctate o registrate

Ver el tema anterior Ver el tema siguiente Ir abajo  Mensaje [Página 1 de 1.]

wibly


En muchos casos necesitamos sumar los valores de una columna dado que otra columna (o campo) cumpla una cierta condinción.

En el adjunto (estoy probando la subida de archivos) podemos necesitar sumar la columna B para los registros de ARG. Como nos conviene hacerlo?

Adrián Wibly
Archivos
Consulta1.xls
No tienes los permisos para descargar los archivos.
(17 KB)

2 Yo prefiero SUMAPRODUCTO el 11/04/12, 10:26 am

wibly


Subo archivo con las dos opciones:

=SUMAR.SI(A1:A5;"ARG";B1:B5)
=SUMAPRODUCTO((A1:A5="ARG")*(B1:B5))

Particularmente prefiero la función SUMAPRODUCTO. Es una de mis funciones preferidas... esta nos da la ventaja de poder definir muchos criterios a la vez, para diferentes campos.

Por lo que veo la subida de archivos ya está funcionando.

Saludos

Adrián Wibly
Archivos
Respuesta Consulta1.xls
No tienes los permisos para descargar los archivos.
(17 KB)

Invitado


Invitado
Hola Adri

Efectivamente, funciona perfecto y muy rápido.

Enhorabuena, creo que esto va por buen camino

Un abrazo

Alberto

wibly


Sí Alberto!!! vamos avanzando,
gracias de nuevo!

DanielBiblia


Comparto la opinión de que la función SUMAPRODUCTO es preferible. Esta función, que es muy versatil, lamentablemente no es muy conocida.

En el caso planteado, se reliza la suma en base a un solo criterio de selección ("ARG"), pero en otros casos puede darse que exista más de un criterio de selección, en cuyo caso habra que usar la nueva función SUMAR.SI.CONJUNTO, que como se sabe admite más de un criterio de selección.

Lo indicado de la función SUMAR.SI.CONJUNTO la hace bastante versatil, pero tiene la limitación de que todas las condiciones que se utilicen como argumentos de dicha función tienen que cumplirse TODAS a la vez, es decir que se trata de una función lógica Y() implícita.

Más versatil que la función SUMAR.SI.CONJUNTO es la función SUMAPRODUCTO, ya que en esta función podemos indicar diversos criterios de selección conectados por los operadores + (equivale a Y, and) y * (equivale a O, or), lo cual le da una flexibilidad única.

SAKKAR


Solo por metiche Twisted Evil y también porque me parece interesante a la hora de que varios conceptos sean de caracter OR y no del tipo AND, podremos siempre reemplazar las formulas por un pequeño código de VBA anclado a un botón o a alguna acción que lo dispare...

COLUMNA 1 COLUMNA 2
ARG 23
ESP 32
VEN 02
FRA 66
URU 49

Supongamos que queremos sumar cuando sea ARG o cuando sea URU

Sheets("hoja1").activate
sheets ("hoja1").raqnge("columna 2;fila 2")
while activecell.value<>""
if activecell.offset(0,-1).value="ARG" OR activecell.offset(0,-1).value="URU" then
suma=suma+activecell.value
activecell.offset(1,0).select
else
activecell.offset(1,0).select
endif
wend


Obviamente que el código se podría optimizar, pero de esta forma se entiende mucho mejor... solo resta anidarlo al evento que qerramos y en la variable suma tendremos el sumar si pero con condiciones OR.

Saludos a todos

Sakkar

wibly


Daniel y Sakkar, gracias por sus comentarios.
Sakkar, VBA no es mi fuerte, en realidad soy un apenas principiante. ¿Podrías subir un archivo con la alternativa que planteás?, porque estuve intentando pero no lo logré.
Saludos!
Adrián Wibly

ioyama


Hola a todos

Simplemente como comentario y a fin de ir probando el fucnionamiento del foro.

SUMAPRODUCTO vs CONTAR.SI (o SUMAR.SI)

Yo también soy de los que tirán rápidamentede SUMAPRODUCTO, ahora bien decir en detrimento de esta función que el consumo de recursos es muy superior a emplear SUMAR.SI o CONTAR.SI.

Por otra parte recordar la función que llegó con el 2007 de SUMAR.SI.CONJUNTO

Un saludo desde Vitoria

Aslam


Prefiero SumarProducto,
anque en Excel 207 y 2010 disponemos de una formula SUMAR.SI.CONJUNTO que es lo mismo que sumarProducto pero Problema es que si usamos este formula SUMAR.SI.CONJUNTO este no funciona son excel 2003.
si yo uso este formula en un libro y guardo el archivo para excel 2003 y quiero abrir lo en excel 2003 no me funcionara, por esto orefiero Sumarproducto.

Ver el tema anterior Ver el tema siguiente Volver arriba  Mensaje [Página 1 de 1.]

Permisos de este foro:
No puedes responder a temas en este foro.