UniversoExcelForo

Respuesta a consultas.
Fecha de creación: 09.Abril.2012

Fundadores: Wibly,Tyno,Servando,Sakkar,Rosendo2,RMaximo,Railar,Mcoronel,Ioyama,Igtelo,Hugotron,Drochar,Dedos,Alberto,Adolfo


No estás conectado. Conéctate o registrate

Ver el tema anterior Ver el tema siguiente Ir abajo  Mensaje [Página 1 de 1.]

Visor


Estimados amigos del foro, en un formulario tengo dos listbox se carga con informacion y cada linea de listbox debe pasar de L1 a L2 con el boton flecha abajo pero al hacerlo se limpia el contenido de L1. En realidad lo que quiero es que se mantenga la informacion en L1 lo que debe suceder es que la linea que se selecciona para que pase de a L2 es la que se desaparece pero el resto debe mantenerse.

Si sigo pasando las lineas de L1 a L2 hasta agotar todas las lineas de L1 entonces L2 queda vacio y L2 queda llena con todas las lineas que antes estaban en L1.

Subo un archivo para que lo vean

Archivo muestra

jhon1904

avatar
hola visor

veo que estas preguntado lo mismo de otro foro el cual ya se le dio respuesta, valida el tema que te adjuntare.

http://www.universoexcelforo.com/t2382-pasar-de-un-listbox-a-otro-con-fecha-actual-y-pero-quitando-la-fila-en-el-primer-listbox

Saludos,


_________________
Jhon Mayorquin
https://www.facebook.com/groups/1908894496046888/

Visor


Gracias Jhon
Efectivamente muy gentimente aquí he recibido tu ayuda. Lo que sucede es que el código sigue funcionando muy bien en mi computador en la que tengo excel 2013

No obstante me compre otra laptop y en esta me ha venido windows 10 de 64 y excel 2016
En este nuevo excel no me funcionaba y almenos con ayuda de los expertos funciona hasta lo que puedes observar en el ejemplo. 

Ahora bien con el código que uso con el de excel 2013 los listbox muestran el contenido de L1 y al pasar una linea a L2 el contenido se mantiene en L1 excepto la linea que se ha pasado a L2
L2 se va llenando poco a poco a medida que se va pasando las lineas. (Igual con el botón de retorno pero alreves)

En excel 2016 esto no sucede, es decir al activar el formulario muestra contenido en L1 pero al seleccionar una linea y pasarlo a L2, sucede que desaparece totalmente el resto del contenido de L1
Ese es mi problema ahora

Ver el tema anterior Ver el tema siguiente Volver arriba  Mensaje [Página 1 de 1.]

Permisos de este foro:
No puedes responder a temas en este foro.