UniversoExcelForo

Respuesta a consultas.
Fecha de creación: 09.Abril.2012

Fundadores: Wibly,Tyno,Servando,Sakkar,Rosendo2,RMaximo,Railar,Mcoronel,Ioyama,Igtelo,Hugotron,Drochar,Dedos,Alberto,Adolfo


No estás conectado. Conéctate o registrate

Ver el tema anterior Ver el tema siguiente Ir abajo  Mensaje [Página 1 de 1.]

pitiki6


Buenas noches:

He estado mirando por el foro a ver si había un caso parecido al mío y no lo he encontrado, así que me he decidido a escribir por aquí por si alguien me pudiera echar una manita en algo que me trae de cabeza:

En el fichero de prueba que adjunto, tengo dos hojas (INDICADORES e INICIO). Cuando señalo un código ya establecido en la hoja INDICADORES, automáticamente se me pasa la información de la columna B (que coincide con el código escrito en alguna de las celdas de las columnas D, E, F ó G) a celdas concretas de la hoja INICIO. Pues bien, como es una función de SI.ERROR conjuntamente con ÍNDICE y COINCIDIR en la columna J, cuando en la hoja inicio SEÑALO UNA SOLA VEZ el código que necesito en el mismo rango horizontal de fila ("1ob" ó "2ob" ó "3ob"...) la fórmula empleada de SI.ERROR empleada en la columna J  de la hoja INICIO funciona perfecta. El problema viene cuando tengo que señalar más de una vez el mismo código dentro del mismo rango de fila horizontal. Ahí, la fórmula hace que el contenido de la columna B de la hoja INDICADORES se repita tantas veces como código "1ob" ó "2ob"... tenga señalado.

RESUMIENDO:

Primero señalé en la columna F de la hoja INICIO, la siguiente función:
=SI.ERROR(INDICE(INDICADORES!$B$5:$B$1286;COINCIDIR("1ob";INDICADORES!D$5:D$1286;0);1);"")&SI.ERROR(INDICE(INDICADORES!$B$5:$B$1286;COINCIDIR("1ob";INDICADORES!E$5:E$1286;0);1);"")&SI.ERROR(INDICE(INDICADORES!$B$5:$B$1286;COINCIDIR("1ob";INDICADORES!F$5:F$1286;0);1);"")&SI.ERROR(INDICE(INDICADORES!$B$5:$B$1286;COINCIDIR("1ob";INDICADORES!G$5:G$1286;0);1); "")   ------> Éste es el ejemplo de la celda F3. A medida que vamos descendiendo hasta la celda F22, lo único que cambia de la fórmula es el código a señalar "2ob", "3ob"...hasta "20ob"

Pensé en reescribir la fórmula para que, de alguna manera, se pudiera detener lo que quedaba de función si ya se había cumplido la misma en alguna de las cuatro condiciones que se señalan (cada condición está separada por "&"). Pero no tengo ni idea de como hacerlo y he probado de todo.

Luego, pensé que, para hacer más fácil la identificación de la condición cumplida había que segmentar la fórmula en 4 partes, una para cada columna y así poder seleccionar y copiar una sola vez la información en una quinta columna. Así que la fórmula (por ejemplo para el rango F3:I3) quedó así (es la misma que la anterior pero dividida en cuatro partes):

EN F3 ------> =SI.ERROR(INDICE(INDICADORES!$B$5:$B$1286;COINCIDIR("1ob";INDICADORES!D$5:D$1286;0);1);"")
EN G3 ------> =SI.ERROR(INDICE(INDICADORES!$B$5:$B$1286;COINCIDIR("1ob";INDICADORES!E$5:E$1286;0);1);"")
EN H3 ------> =SI.ERROR(INDICE(INDICADORES!$B$5:$B$1286;COINCIDIR("1ob";INDICADORES!F$5:F$1286;0);1);"")
EN I3 ------>   =SI.ERROR(INDICE(INDICADORES!$B$5:$B$1286;COINCIDIR("1ob";INDICADORES!G$5:G$1286;0);1);"")

Entonces, el objetivo es que en la columna J se copie el contenido UNA SOLA VEZ de la primera o de la última celda con texto del rango F3:I3. El usar el filtro avanzado no me es práctico porque lo que pretendo es que esto suceda de manera automática y sin desplazamiento u ocultación de columnas ni nada de eso. Si llegara a conseguir esto, lo que había pensado hacer era ocultar el rango de la columna F a la columna I y dejar visible sólo la columna J.

Todo esto lo estoy intentando llevar a cabo mediante fórmula y no mediante macro (porque ahí sí que ando muuuuy perdido). Yo necesitaría hacerlo mediante fórmula. Para que se vea más claro lo que expongo (que ha sido largo), les adjunto un fichero para que lo miren a ver si me pueden dar una solución.

He intentado expresarlo de la manera más fácil y más rápida posible para que se pudiera comprender bien. Lo siento si me he excedido o no he sabido expresarlo de otro modo. Saludos.
Archivos
PRUEBA.xlsx
No tienes los permisos para descargar los archivos.
(18 KB)

ioyama

avatar
Hola

No sé si te he entendido

Revisa el adjunto

Un saludo desde Vitoria
Archivos
Observaciones_io_170905.zip
No tienes los permisos para descargar los archivos.
(14 KB)

Ver el tema anterior Ver el tema siguiente Volver arriba  Mensaje [Página 1 de 1.]

Permisos de este foro:
No puedes responder a temas en este foro.