UniversoExcelForo

Respuesta a consultas.
Fecha de creación: 09.Abril.2012

Fundadores: Wibly,Tyno,Servando,Sakkar,Rosendo2,RMaximo,Railar,Mcoronel,Ioyama,Igtelo,Hugotron,Drochar,Dedos,Alberto,Adolfo


No estás conectado. Conéctate o registrate

Ver el tema anterior Ver el tema siguiente Ir abajo  Mensaje [Página 1 de 1.]

autoca


Hola a todos,

Estoy intentando utilizar la fórmula INDIRECTO() para recuperar el nombre de una hoja que esta en mi libro para usarla en una formula.

Si utilizo:

=SUMAPRODUCTO(('825'!$B$5:$B$30=$C$5)*('825'!$D$3:$BD$3=D$3)*('825'!$D$5:$BD$30))

me devuelve el valor esperado 

pero si utilizo la función INDIRECTO así:

=SUMAPRODUCTO(INDIRECTO($A6&"!$B$5:$B$30=$C$5")*INDIRECTO($A6&"!$D$3:$BD$3=!D$3")*INDIRECTO($A6&"!$D$5:$BD$30"))

Donde A6 tiene el valor 825

me devuelve #¡REF!

¿Alguna pista de que hago mal?

Muchas gracias!
Luis

ioyama

avatar
Hola autoca

Estás aplicando la función INDIRECTO a demasiados parámetros, tienes que cortar en el igual.

Te adjunto un ejemplo con un par de hojas con datos y la función indirecto en otra hoja

Un saludo desde Vitoria
Archivos
Indirecto_io_170529.zip
No tienes los permisos para descargar los archivos.
(8 KB)

Ver el tema anterior Ver el tema siguiente Volver arriba  Mensaje [Página 1 de 1.]

Permisos de este foro:
No puedes responder a temas en este foro.