UniversoExcelForo

Respuesta a consultas.
Fecha de creación: 09.Abril.2012

Fundadores: Wibly,Tyno,Servando,Sakkar,Rosendo2,RMaximo,Railar,Mcoronel,Ioyama,Igtelo,Hugotron,Drochar,Dedos,Alberto,Adolfo


No estás conectado. Conéctate o registrate

Ver el tema anterior Ver el tema siguiente Ir abajo  Mensaje [Página 1 de 1.]

mtrilce

avatar
Estimados todos,

Tengo una fórmula matricial que copia los valores de una columna de manera ordenada, pero omitiendo las celdas vacías:

{=+SI.ERROR(SI(FILAS(C$1:C2)>CONTARA(B2:B300)-1; ""; INDICE(B:B; K.ESIMO.MENOR(SI(B2:B300<>"";FILA(B2:B300));FILAS(C$1:C2))));"")}

Sin embargo, al copiar los datos, omite el primer valor... ¿Qué está fallando en mi fórmula?

Adjunto el archivo. Muchas gracias por su apoyo

Marcela
Archivos
k-esimo.xlsx
No tienes los permisos para descargar los archivos.
(44 KB)

ioyama

avatar
Hola

Tu error está en el rango de la columna C

=SI.ERROR(SI(FILAS(C$2:C2)>CONTARA(B2:B300)-1; ""; INDICE(B:B; K.ESIMO.MENOR(SI(B2:B300<>"";FILA(B2:B300));FILAS(C$2:C2))));"")


Tú ha puesto C$1:C2, creo que con ese cambio debería funcionarte

Un saludo desde Vitoria

mtrilce

avatar
Buenos días Ioyama,

Muchísimas gracias!. Ahora sí funciona correctamente.

Un saludo desde Perú

Marcela

Ver el tema anterior Ver el tema siguiente Volver arriba  Mensaje [Página 1 de 1.]

Permisos de este foro:
No puedes responder a temas en este foro.