UniversoExcelForo

Respuesta a consultas.
Fecha de creación: 09.Abril.2012

Fundadores: Wibly,Tyno,Servando,Sakkar,Rosendo2,RMaximo,Railar,Mcoronel,Ioyama,Igtelo,Hugotron,Drochar,Dedos,Alberto,Adolfo


No estás conectado. Conéctate o registrate

Ver el tema anterior Ver el tema siguiente Ir abajo  Mensaje [Página 1 de 1.]

stifftico97


introduscos números en la celda A por medio de un user form pero la fórmula de excel =SUMA(A9:A700) no recocé los datos introduciodos de esta menera y el siguiente código tampoco
Private Sub Worksheet_Activate()       ' tampoco funciona el evento calculate o el evento change 
A1sum = Range("A9:A700")
resultado = Application.WorksheetFunction.Sum(A1sum)    ' este codigo va en la hoja que uso 
Range("E5") = resultado
End Sub

'''''''yo envío los datos ala celda"A"mediante user form
Pero el dato de la celda E5 no se actualiza conforme introduzco números
Entonces como sumo todos los valores introducidos por user form en la fila A
Archivos
suma de num introducidos por user form.xlsm
No tienes los permisos para descargar los archivos.
(24 KB)

servando


Buen día para tod@s.

Yo creo que se tiene que convertir txtnum a valor.

Te adjunto fichero con mis propuestas.

Un saludo desde Vitoria, Servando
Archivos
Copia de suma de num introducidos por user form.xlsm
No tienes los permisos para descargar los archivos.
(32 KB)

Igtelo

avatar
Resuelto!!

Servando: Gracias por tu solución y tiempo.

Saludos
Ignacio Téllez

Contenido patrocinado


Ver el tema anterior Ver el tema siguiente Volver arriba  Mensaje [Página 1 de 1.]

Permisos de este foro:
No puedes responder a temas en este foro.