UniversoExcelForo

Respuesta a consultas.
Fecha de creación: 09.Abril.2012

Fundadores: Wibly,Tyno,Servando,Sakkar,Rosendo2,RMaximo,Railar,Mcoronel,Ioyama,Igtelo,Hugotron,Drochar,Dedos,Alberto,Adolfo

No se pueden hacer consultas de Excel o VBA por mensaje privado.
Utiliza el botón buscar del foro y te ahorras tiempo para obtener "ayuda".

No estás conectado. Conéctate o registrate

Ver el tema anterior Ver el tema siguiente Ir abajo  Mensaje [Página 1 de 1.]

1RESUELTO Extraer datos con dos criterios el 07/06/16, 08:42 pm

Omaet


Hola!!

Tengo un archivo en el que tengo un listado de alumnos de una escuela, con sus metrias, calificaciones y nombre del maestro.

Necesito extraer la calificación de ciertas personas en determinadas materias a otra tabla.

Agradecería mucho su ayuda.
Archivos
calificaciones.xlsx
No tienes los permisos para descargar los archivos.
(12 KB)

2RESUELTO Re: Extraer datos con dos criterios el 07/06/16, 11:58 pm

tyno


Hola Omaet.
Hay casos donde como ya sabemos que las condiciones no se repiten en nuestra matriz, es decir, tomando tu archivo sabemos que solo existe una sola relación nombre/materia y a su vez el valor buscado es un valor numérico, entonces podemos utilizar la función de Excel SUMAR.SI.CONJUNTO que en este caso particular funciona para buscar un resultado en base a mas de un criterio. Prueba si te sirve esto en la celda I3

=SUMAR.SI.CONJUNTO($E$3:$E$42;$B$3:$B$42;G3;$C$3:$C$42;H3) 

Luego la aplicas a las demás celdas.

Saludos

3RESUELTO Re: Extraer datos con dos criterios el 08/06/16, 08:19 am

ioyama


Hola

Otra opción
Código:


=INDICE($E$3:$E$42;COINCIDIR(G3&H3;$B$3:$B$42&$C$3:$C$42;0))



Introducida matricialmente (Contrl+Mayúculas+Intro, en vez de sólo Intro)

Un saludo desde Vitoria

4RESUELTO Gracias el 08/06/16, 02:50 pm

Omaet


Muchas gracias Tino por tu respuesta, pueda ser que algo hice mal porque no me arrojó el resultado, agradezco tu tiempo.

ioyama funcionó perfecto, te agradezco tu ayuda y tu tiempo.

Saludos.

Ver el tema anterior Ver el tema siguiente Volver arriba  Mensaje [Página 1 de 1.]

Permisos de este foro:
No puedes responder a temas en este foro.