UniversoExcelForo

Respuesta a consultas.
Fecha de creación: 09.Abril.2012

Fundadores: Wibly,Tyno,Servando,Sakkar,Rosendo2,RMaximo,Railar,Mcoronel,Ioyama,Igtelo,Hugotron,Drochar,Dedos,Alberto,Adolfo

No se pueden hacer consultas de Excel o VBA por mensaje privado.
Utiliza el botón buscar del foro y te ahorras tiempo para obtener "ayuda".

No estás conectado. Conéctate o registrate

Ver el tema anterior Ver el tema siguiente Ir abajo  Mensaje [Página 1 de 1.]

Libiallch


Estimado Foro UniversoExcel,

Buenas noches

solicito de su apoyo con lo siguiente:

tengo una Base de Datos y estoy usando la función INDICE y COINCIDIR, el problema está cuando uso la función COINCIDIR y me pide la matriz buscada; pero esta matriz tiene en la celda el valor lógico <=1000 columna K3  y >1800 en L3, al parecer no acepta valores lógicos, ya que cuando lo pruebo solo colocando un número si me sale el resultado.

Cómo puedo hacer para que me acepte los valores lógicos.

adjunto imagen y el archivo
Archivos
ANALISIS_DUDAS_2.xlsx
No tienes los permisos para descargar los archivos.
(219 KB)

wibly


Hola Libiallch,

Se me ocurren por lo menos 3 formas de hacerlo... pero antes de avanzar comenta que esperas que se haga cuando el costo se encuentra entre 1.000 y 1.800, porque la primer condición es de "<= 1.000" y la segunda de "> 1.800".

Espero que contestes para avanzar en una propuesta y no abandones el tema como lo hiciste con tu primer consulta:no:.

Saludos

wibly


Para ir avanzando...

Tu fórmula es :
=INDICE($E$4:$F$8;COINCIDIR(D18;$B$4:$B$8;0);COINCIDIR(I18;$E$3:$F$3;0))

Alternativa 1:
=INDICE($E$4:$F$8;COINCIDIR(D18;$B$4:$B$8;0);SI(I18<=1000;1;2))
Fijate que acá con un simple SI se resuelve que te traiga el valor según la columna que corresponda.

Alternativa 2:
=BUSCARV(D18;$B$4:$F$8;SI(I18<=1000;4;5);0)
Fijate que esta fórmula es más sencilla, solo tiene un BUSCARV y un SI.

Tené en cuenta que en estos casos el criterio para el costo es de "<= 1.000" o "> 1.000"... esto te consulte en mi respuesta anterior y veremos lo que dices.

Saludos

Libiallch


Estimado Adrian

buenas noches

gracias por su respuesta, lo que deseo es que segun el monto jale los descuentos de la tabla, es decir, si la tienda es SURCO y el costo es menor o igual a 1,000 debe salir como respuesta 0.02,  y si la tienda es SURCO y el costo mayor de 1,000 debe salir como respuesta 0,08 y si de acuerdo a los valores de las tablas de los valores de TIENDA y COSTO.

He vuelto a adjuntar el reporte excel, corrigiendo los valores, debe decir <= 1000 y > 1000, en el anterior coloque por error > 1800 (tienes razón en lo que indicaste)
he probabdo con el primer, Indice, Coincidir y la condicional SI, y efectivamente si me sale, pero quisiera entender en la función SI cuando es verdadero colocas 1 caso contrario 2, aqui no entiendo el uso del 1 y 2, por favor me podrias explicar?

gracias y quedo atento a su respuesta.

saludos Libia

estoy prob

Libiallch


Estimado Adrian

buenas noches

con respecto a mi última consulta ya no lo considere, ya lo entendí.

muchas gracias, estoy usando la primera opción que me diste que es lo que queria usando Indice , Coincidir junto con el condicional SI.

gracias y con esto está solucionado.

Libia Linares

wibly


Me alegra que haya quedado el tema solucionado!

Saludos!

Ver el tema anterior Ver el tema siguiente Volver arriba  Mensaje [Página 1 de 1.]

Permisos de este foro:
No puedes responder a temas en este foro.