UniversoExcelForo

Respuesta a consultas.
Fecha de creación: 09.Abril.2012

Fundadores: Wibly,Tyno,Servando,Sakkar,Rosendo2,RMaximo,Railar,Mcoronel,Ioyama,Igtelo,Hugotron,Drochar,Dedos,Alberto,Adolfo

No se pueden hacer consultas de Excel o VBA por mensaje privado.
Utiliza el botón buscar del foro y te ahorras tiempo para obtener "ayuda".

No estás conectado. Conéctate o registrate

Ver el tema anterior Ver el tema siguiente Ir abajo  Mensaje [Página 1 de 1.]

niangari


Hola a todos. De nuevo escribo a ver si me ayudan a resoilver este dilema jaj.

Estoy tratando de que la columna M me diga cuando ALGUNO (CUALQUIERA) de las fechas de la columna L es mayor al valor de la columna F.

El tema es que sólo necesito que me diga ésto para las filas que están POR ENCIMA del valor que estoy evaluando. Ejemplo;
F9 es menor al valor de una de las celdas L7 o L9. Entonces está bien que la fórmula que muestre TRUE. Ahora necesito que automáticamente al evaluar F10, se busque si el valor (fecha) es menor a alguna de las fechas de L7, L8 Y L9.

Al pasar a F11, que se evalúen L7, L8, L9 y L10. Y así sucesivamente. Cuando arrastro la fórmula solo toma las 2 anteriores: http://screencast.com/t/uQHL7z5bzKAI

En la columnas N y O hay algunos intentos mios para lograrlo.

Gracias por la ayuda!


Pd: Subo el documentohttp://screencast.com/t/uQHL7z5bzKAI
Archivos
sample1.xlsx
No tienes los permisos para descargar los archivos.
(20 KB)

tyno


Hola de nuevo Nicolas.

Te paso el archivo con una formula en la columna M que creo es lo que necesitas segun entendi. Cualquier cosa avisas. Saludos.
Archivos
sample1.xlsx
No tienes los permisos para descargar los archivos.
(21 KB)

niangari


Muchísimas gracias! Era lo que buscaba. Ahora intento ir un paso más allá, y quizá es la hora, o la falta de experiencia en excel pero no puedo.

Trato ahora de que en lugar de que sea "TRUE" sea una operación.
Ésta sería asi: cuándo se cumpla la condición [ (L$7:L7;">"&F8)<>0 ] Quiero que sume el valor de columna J para esa fila con las demás filas que cumplan la condición.

Si en F10 < L9 (true) y también F10 < L7 (TRUE) pero F10 > L9 (false) entonces que se sumen los valores de J9 + J7 + 0 (J9).

Talves es la hora pero no logro que sume a la misma fila, sólo que haga esto: http://screencast. Com/t/uCou5Zs5KBMb

tyno


Por aquí estoy de vuelta.
Ahi va de nuevo el archivo con otra formula en la columna N, en este caso es una formula matricial, que creo resuelve tu planteo, anidada dentro de la misma formula de la columna M en reemplazo de valor verdadero TRUE. Segun lo que entendí, en caso que se cumpla la primera condicion entonces sumar cualquier valor de la columna J siempre y cuando las respectivas referencias de la columna L sean distintas de 0 y menor al valor de referencia de la columna F. Como siempre proba y me avisas. Saludos.
Archivos
sample1.xlsx
No tienes los permisos para descargar los archivos.
(21 KB)

tyno


Perdon, te pase el mismo archivo anterior, ahora si te subo el ultimo con la nueva formula. Bye.
Archivos
sample1.xlsx
No tienes los permisos para descargar los archivos.
(23 KB)

niangari


Gracias por tu respuesta!! Sigo intentando, jaja perdón tanta molestia! pero es esto lo que busco: http://screencast.com/t/2OChgetP

Igual lo sigo buscando.

GRACIAS POR LA AYUDA!!

tyno


mmmmm...creo que puse al reves el signo. En la formula que te he pasado esta asi: =SI(MAX($L$7:L9)>F10;SUMA(SI($L$6:L9<F10;SI($L$6:L9<>0;$J$6:J9)));"FALSE")por lo que me parece que deberia ir asi: =SI(MAX($L$7:L9)>F10;SUMA(SI($L$6:L9>F10;SI($L$6:L9<>0;$J$6:J9)));"FALSE"), simplemente hay que dar vuelta el signo menor por mayor en esta parte $L$6:L9>F10, luego que hagas el cambio acordate de oprimir simultaneamente sobre la formula las teclas Ctrl+Shift+Enter para convertir la formula en matricial. Saludos.

niangari


Hola!! gracias avance mucho con tu ayuda!
Espero compensártelo alguna vez jaj.

Hay algunos detalles, a ver si me puedes ayudar a pulirlos. La fórmula compara y suma los valores de el valor MÁXIMO de fechas (de L contra F), pero no de TODAS las fechas que sean mayores que F.

Me explico? que la idea sería que TODAS las filas que cumplan la condición se sumen se te ocurre algo?

GRACAS!!

niangari


nO! era la hora, pero un café me hizo darme cuenta de mi tontería.. Está perfecto! es lo que necesitaba!

Si quieres darle un vistazo a la fórmula terminada (aunque sea por curiosidad jaja).

De verdad gracias por todo, voy a dormir y manana empezaré realmente a trabajar la hoja jaja.

Saludos, GRACIAS! y una buena noche
Archivos
sample1.xlsx
No tienes los permisos para descargar los archivos.
(24 KB)

tyno


Ja, justo te acababa de redactar un manual explicandote como funcionaba la formula que estamos viendo para que tengas un poco mas de idea y poder explayarte mejor. No es facil darse a entender por este medio. Pero bueno me alegro que todo resultara. Un saludo compatriota.

niangari


Jaja si quieres compartir el manual no estaría mal! jaja.. Cool

Ya que la verdad me tomó por sorpresa el concepto de "fórmula matricial". Entendí y pude aplicar la acción de "apretar las 3 teclas del teclado para que la fórmula haga lo que necesito", pero no pasé de ese nivel de entendimiento. Talvez también es por la hora, pero en fin, estaremos hablando estos días.

Saludos!

Ver el tema anterior Ver el tema siguiente Volver arriba  Mensaje [Página 1 de 1.]

Permisos de este foro:
No puedes responder a temas en este foro.