UniversoExcelForo

Respuesta a consultas.
Fecha de creación: 09.Abril.2012

Fundadores: Wibly,Tyno,Servando,Sakkar,Rosendo2,RMaximo,Railar,Mcoronel,Ioyama,Igtelo,Hugotron,Drochar,Dedos,Alberto,Adolfo

No se pueden hacer consultas de Excel o VBA por mensaje privado.
Utiliza el botón buscar del foro y te ahorras tiempo para obtener "ayuda".

No estás conectado. Conéctate o registrate

Ver el tema anterior Ver el tema siguiente Ir abajo  Mensaje [Página 1 de 1.]

rosendo2


Buenas Días, tardes  o noche compañeros, gusto de saludarles. Por favor  necesito de su valiosa colaboración para lograr lo siguiente: incrementar un valor de uno (1) en uno  hasta llegar al número quince (15), y una vez que llegue a 15 es éste el que debe quedar fijo y repetirse en lo sucesivo (15, 15, 15, …., 15).
 
Adjunto archivo con macro que permite incorporar el valor 1 e ir aumentando en lo sucesivo, pero como mencioné necesito que se detenga en 15 y que lo mantenga fijo a partir del momento en que alcance este valor, por supuesto no sé cómo hacerlo.
 
Agradeciendo de ante mano su valiosa colaboración
 
Cordial saludo
Rosendo - Venezuela

Igtelo


Hola Rosendo.

Con fórmula:
Supongamos que en A3 escribes 1
En A4 =SI(A3<>15,A3+1,15), la copias hasta donde necesites y listo


Código:
Sub Rosendo()

ActiveCell = 1       'Celda donde inician tus datos
Selection.AutoFill ActiveCell.Resize(15), Type:=xlFillSeries 'Rellena del 1 al 15
ActiveCell.End(xlDown).Select  'Se va hasta el 15
Selection.Copy                      'Lo copia
ActiveCell.Resize(500).PasteSpecial xlValues '<== Lo pega para 500 celdas
Application.CutCopyMode = False                'Libera portapapeles
End Sub

También te podría servir éste:
Código:
Sub Rosendo2()
ActiveCell = 1
Selection.AutoFill ActiveCell.Resize(15), Type:=xlFillSeries
ActiveCell.End(xlDown).Resize(500) = 15

End Sub

Saludos
Ignacio Téllez

rosendo2


Gracias Ignacio me funciona, y prefiero quedarme con la formula que me planteas al inicio.

Cordial saludo

Ver el tema anterior Ver el tema siguiente Volver arriba  Mensaje [Página 1 de 1.]

Permisos de este foro:
No puedes responder a temas en este foro.