UniversoExcelForo

Respuesta a consultas.
Fecha de creación: 09.Abril.2012

Fundadores: Wibly,Tyno,Servando,Sakkar,Rosendo2,RMaximo,Railar,Mcoronel,Ioyama,Igtelo,Hugotron,Drochar,Dedos,Alberto,Adolfo

No se pueden hacer consultas de Excel o VBA por mensaje privado.
Utiliza el botón buscar del foro y te ahorras tiempo para obtener "ayuda".

No estás conectado. Conéctate o registrate

Ver el tema anterior Ver el tema siguiente Ir abajo  Mensaje [Página 1 de 1.]

1RESUELTO Condicion rango en blanco el 13/08/15, 12:11 pm

Rayman


Hola,
Tengo una duda hace varios días y no estoy encontrando una solución, por eso me dirijo a ustedes para perdirles ayuda.

Tengo un rango de celdas (C3:C15) que pueden estar en blanco o que tengan una letra, el caso es que necesito sumar otro rango de celdas (D3:E15) si las celdas del rango C3:C15 se encuentran en blanco.
he intentado con la siguiente formula, pero me da error...

+SUMAR.SI('Q1'!C3:C15="";SUMAPRODUCTO((EXTRAE('Q1'!$A$3:$A$15;3;1)=IZQUIERDA(B$1))*'Q1'!$D$3:$E$15);0)

en el ejemplo se ve mejor
Archivos
Ejem.Foro.xls
No tienes los permisos para descargar los archivos.
(27 KB)

2RESUELTO Re: Condicion rango en blanco el 13/08/15, 01:14 pm

adolfo castro


Hola buenas tardes, no se si te explicas malamente, o tan solo has subido parte de lo que precisas, pues veo que en el rango también esta involucrado el rango a, sin embargo no veo datos en ella, no se si me explico o tu no te explicas bien, por lo que subiría una descripción mas completa de lo que precisas.

saludos Adolfo castro

3RESUELTO Re: Condicion rango en blanco el 13/08/15, 01:22 pm

Rayman


hola Adolfo....gracias por tu interes y esfuerzo en ayudarme, y disculpa si me expreso mal... a ver si podemos aclararnos.

no te entiendo cuando dices que faltan mas datos, y que falta el rango A,
el rango A está en la hoja Q1, y es el codigo del articulo (pequeño, mediano, grande)
El calculo si te fijas lo realizo en la hoja "Mes"
Donde necesito que realize la comprobacion si es blanco que sume el rango y si hay una letra no, en la columna "C" de la hoja Q1

adjunto uno nuevo, aver si ahora se ve mejor
Archivos
Ejem.Foro2.xls
No tienes los permisos para descargar los archivos.
(27 KB)

4RESUELTO Re: Condicion rango en blanco el 13/08/15, 02:18 pm

Rayman


bueno tengo que decir que al final he dado con la solucion...

=+SUMAPRODUCTO((EXTRAE('Q1'!A3:A11;3;1)="p")*('Q1'!C3:C11<>"B")*'Q1'!D3:E11)
=+SUMAPRODUCTO((EXTRAE('Q1'!A3:A11;3;1)="m")*('Q1'!C3:C11<>"B")*'Q1'!D3:E11)
=+SUMAPRODUCTO((EXTRAE('Q1'!A3:A11;3;1)="g")*('Q1'!C3:C11<>"B")*'Q1'!D3:E11)

5RESUELTO Re: Condicion rango en blanco el 13/08/15, 02:26 pm

adolfo castro


Sigue sin quedarme muy claro, pero vamos, te adjunto formula sumar.si.conjunto, a ver si te sirve, observa como trabaja y si no puedes adaptarla comunicas
Archivos
Ejem.Foro.xlsx
No tienes los permisos para descargar los archivos.
(16 KB)

6RESUELTO Re: Condicion rango en blanco el 13/08/15, 03:28 pm

Rayman


Te aclaro que la formula no es la que busco pues te recuerdo como lo pongo en el ejemplo.
que dependiendo de la columna A en Q1, si son (pequeñas,medianas,grandes) serian calculos diferentes.
por eso en  mi ejemplo, los datos correctos son :

En hoja "Mes"
B3 = 85
D3=  50
F3 = 50

salu2

7RESUELTO Re: Condicion rango en blanco el 13/08/15, 04:46 pm

Igtelo


Hola sres.

Si lo que quieres sumar son los que están en blanco, cambia a: C3:C11="" 
Como lo tienes si se pone cualquier caracter que no sea B, lo sumará.

Saludos
Ignacio Téllez

8RESUELTO Re: Condicion rango en blanco el 13/08/15, 05:27 pm

Rayman


hola Igtelo, se agradece la ayuda y el detalle. Me biene fenomenal.


salu2

9RESUELTO Re: Condicion rango en blanco el 14/08/15, 03:01 am

adolfo castro


Hola, buenos días, en un primer lugar pedirte disculpas pues creo que ayer tuve un dia de nublados y no vi bien la pregunta, asi que tan solo disculparme pues en un primer momento no me entere bien de la cuestión,

saludos Adolfo castro

10RESUELTO Re: Condicion rango en blanco el 14/08/15, 03:56 am

Rayman


hola Adolfo...no te preocupes que no pasa nada...ademas esos dias los tenemos todos...y seria al reves, la gracias las tengo que dar yo por interés mostrado por tu parte.


Un saludo afectuoso.

Ver el tema anterior Ver el tema siguiente Volver arriba  Mensaje [Página 1 de 1.]

Permisos de este foro:
No puedes responder a temas en este foro.