UniversoExcelForo

Respuesta a consultas.
Fecha de creación: 09.Abril.2012

Fundadores: Wibly,Tyno,Servando,Sakkar,Rosendo2,RMaximo,Railar,Mcoronel,Ioyama,Igtelo,Hugotron,Drochar,Dedos,Alberto,Adolfo

No se pueden hacer consultas de Excel o VBA por mensaje privado.
Utiliza el botón buscar del foro y te ahorras tiempo para obtener "ayuda".

No estás conectado. Conéctate o registrate

Ver el tema anterior Ver el tema siguiente Ir abajo  Mensaje [Página 1 de 1.]

z5f4r8x


Hola, tengo que aplicar la función Buscarv para búsqueda de artículos con su precio correspondiente a partir del ingreso del código de dicho articulo. La lista de precios  contiene los datos únicamente en una sola columna, la cual no puede ser modificada. Alguna idea de como se puede hacer? Adjunto ejemplo. Gracias.
Archivos
Como aplicar la funcion BuscarV.xlsx
archivo ej
No tienes los permisos para descargar los archivos.
(10 KB)

Igtelo


Hola z5f4...

Es con BUSCARH. Te doy 3 alternativas,espero te sirvan.

Saludos
Ignacio Téllez
Archivos
z5f4r8x-Como aplicar la funcion BuscarV.xlsx
No tienes los permisos para descargar los archivos.
(12 KB)

3RESUELTO Me marca error el 25/04/15, 10:22 am

z5f4r8x


Hola Igtelo, muchas gracias por tu respuesta, es la solución que estaba buscando. La tercera opción que pusiste es la que mas  me gustaría aplicar, la de "solo números", pero cuando me pide excel Habilitar Edición que me lo pidió al abrir el archivo por primera vez , me marca error en la celda en la cual está ésta formula (en las otras opciones funciona de diez las distintas formulas). Cual puede ser el problema que me marca Error ?. Adjunto foto. Saludos.

[img][/img]

Igtelo


Hola Zf.

En el archivo va la fórmula en texto y una macro.

¿Qué versión de Excel usas?

Saludos
Archivos
z5f4r8x-Como aplicar la funcion BuscarV.zip
No tienes los permisos para descargar los archivos.
(24 KB)

z5f4r8x


Excel 2010 professional plus

rmaximo


buenas a los dos, perdona que me entrometa pero es debido a que el numero tiene como separador de decimales un punto cuando aqui en España por ejemplo se usa la coma, de ahi que use la formula para cambiar el punto por la coma.

=SI(IZQUIERDA(A2;6)="Código";SUSTITUIR(EXTRAE(A3;HALLAR("$";A3;1)+1;999);".";",")*1;"")

What a Face

z5f4r8x


Hola a todos, gracias a ambos por la ayuda dada, ahora surgió otro problema, como esos datos están vinculados a datos externos  de una pagina web al actualizarse los datos se mueven de celdas desplazandose hacia abajo o arriba . Quise  organizarlos a través de una tabla dinámica pero como los datos están colocados en una sola columna me es imposible. Alguna sugerencia?.

Igtelo


Hola Zf.

Esto ya es otro tema, lo que concierne a lo que pediste está resuelto.
Si siempre están variando tus datos de posición, "siempre" tendrás que ordenarlos primero.

Creo que ni siquiera viste la macro que te dejé...

Saludos y suerte
Ignacio Téllez

z5f4r8x


Gracias, tema resuelto.

Ver el tema anterior Ver el tema siguiente Volver arriba  Mensaje [Página 1 de 1.]

Permisos de este foro:
No puedes responder a temas en este foro.