UniversoExcelForo

Respuesta a consultas.
Fecha de creación: 09.Abril.2012

Fundadores: Wibly,Tyno,Servando,Sakkar,Rosendo2,RMaximo,Railar,Mcoronel,Ioyama,Igtelo,Hugotron,Drochar,Dedos,Alberto,Adolfo

No se pueden hacer consultas de Excel o VBA por mensaje privado.
Utiliza el botón buscar del foro y te ahorras tiempo para obtener "ayuda".

No estás conectado. Conéctate o registrate

Ver el tema anterior Ver el tema siguiente Ir abajo  Mensaje [Página 1 de 1.]

mariajose1979


Hola: Tengo que sumar los datos de la planilla adjunta siendo que busque los datos duplicados en la columna codigo y sume la cantidad en un registro unico.
Ej:
El codigo 000000315010 tendria que arrojar 21 (14+7) y asi con todo el resto de los registros.
Saludos y gracias por la ayuda.
Archivos
libro para foro.xlsx
No tienes los permisos para descargar los archivos.
(204 KB)

wibly


Hola mariajose1979,

Para hacer lo que pides existen varias alternativas. Algunas son con fórmulas, por ejemplo con SUMAR.SI (algo así: =SUMAR.SI(Hoja1!A:A;A2;Hoja1!D:D)), o SUMAPRODUCTO. Para hacerlo aplicando fórmulas necesitás un campo con todos los códigos. (ver hoja "con fórmulas")

Otra alternativa muy utilizada en estos casos, y a mi entender la más eficiente, es hacerlo con una tabla dinámica. (ver hoja "con tabla dinamica").

Atención: eliminé muchas filas de la base de datos para que el archivo no quede muy pesado.

Si utilizas Tablas Dinámicas lee la ayuda sobre su funcionamiento (tengo que preparar algún tutorial con audio sobre este tema tan importante... mientras tanto puedes ver este video tutorial, creo que te puede ayudar) y ten cuidado que la actualización de las mismas no es automática.

Para ver cómo lograr que una tabla dinámica se actualice automáticamente ver este tema.

Espero que te sea de utilidad.

Saludos
Archivos
libro para foro_adw.xlsx
No tienes los permisos para descargar los archivos.
(35 KB)

3RESUELTO Resuelto el 17/04/15, 01:24 pm

mariajose1979


Gracias Adrián Wibly por tu aporte, ha sido de mucha utilidad.!!!!!!

Ver el tema anterior Ver el tema siguiente Volver arriba  Mensaje [Página 1 de 1.]

Permisos de este foro:
No puedes responder a temas en este foro.