UniversoExcelForo

Respuesta a consultas.
Fecha de creación: 09.Abril.2012

Fundadores: Wibly,Tyno,Servando,Sakkar,Rosendo2,RMaximo,Railar,Mcoronel,Ioyama,Igtelo,Hugotron,Drochar,Dedos,Alberto,Adolfo

No se pueden hacer consultas de Excel o VBA por mensaje privado.
Utiliza el botón buscar del foro y te ahorras tiempo para obtener "ayuda".

No estás conectado. Conéctate o registrate

Ver el tema anterior Ver el tema siguiente Ir abajo  Mensaje [Página 1 de 1.]

modulovar


hola

os cuento mi problema

Tengo una serie de listas que tengo que ordenar, con tamaños diferentes, y se me ocurrió un sistema para hacer este orden más ameno, el problema que tengo es que estoy atascado en un paso y no se me ocurre como hacerlo.

os dejo un ejemplo para que os hagais una idea,
tengo una lista partida por celdas en blanco, y la idea es que al pulsar el botón, comience a contar de arriba a abajo (hasta que llegue el fin) y que cuando llegue a una celda en blanco, el numero aumente en 1.

Os dejo un ejemplo para que lo entendais mejor (El archivo y el resultado)

gracias amigos
Archivos
Contar.zip
No tienes los permisos para descargar los archivos.
(21 KB)

wibly


Hola modulovar,

Necesariamente lo quieres con una Macro?... mira el adjunto... creo que lo puedes resolver con esta fórmula:

=SI(O(A9="";A10="");"";SI(A8="";MAX(B9:B$10)+1;MAX(B9:B$10)))

(para la fila 10... para el resto arrastrar la fórmula)

Espero que te sea de utilidad.

Saludos
Archivos
Contar adw.xlsx
No tienes los permisos para descargar los archivos.
(13 KB)

modulovar


Funciona bastante bién, pero al tener varias listas de diversos tamaños (algunas superan las 5000 entradas) lo necesitaría en plan macro para que fuera más automático

gracias por tu ayuda

wibly


¿Y copiar/arrastrar la fórmula hasta la fila 50000 por ejemplo?, o bien grabar una macro que arrastre la fórmula hasta la fila que se te ocurra y luego pegue los valores (pegado especial >>> valores) para que luego no se te haga pesado el archivo?

Se me ocurren estas alternativas para que pruebe... creo que te deberían servir. Sino veremos si alguien ofrece otra solución.

Saludos

Igtelo


Hola modulovar / Adrián.

Para mi con la fórmula está bien y tenemos que aprovecharla, en cuanto a lo que te dice Adrián de la macro, aquí te dejo el código.


Sub Macro1()

zz = [A1000000].End(xlUp).Row - 2  'P/saber cuantas filas tendrá la fórmula
    
'Fórmula dada por Adrián
ActiveCell.FormulaLocal = "=SI(O(A10="""",A11=""""),"""",SI(A9="""",MAX(B$10:B10)+1,MAX(B$10:B10)))"

ActiveCell.Copy Range("B11", "B" & zz)  'Copia y pega la fórmula en el rango (inicia en B11)
Range("B11", "B" & zz).Copy                'Copia todo el rango de la fórmula
Range("B11").PasteSpecial xlValues       'Lo convierte a valores p/NO hacer pesado el archivo
Application.CutCopyMode = False          'Limpia portapapeles
[A1].Select
End Sub

Saludos
Ignacio Téllez

Ver el tema anterior Ver el tema siguiente Volver arriba  Mensaje [Página 1 de 1.]

Permisos de este foro:
No puedes responder a temas en este foro.