UniversoExcelForo

Respuesta a consultas.
Fecha de creación: 09.Abril.2012

Fundadores: Wibly,Tyno,Servando,Sakkar,Rosendo2,RMaximo,Railar,Mcoronel,Ioyama,Igtelo,Hugotron,Drochar,Dedos,Alberto,Adolfo

No se pueden hacer consultas de Excel o VBA por mensaje privado.
Utiliza el botón buscar del foro y te ahorras tiempo para obtener "ayuda".

No estás conectado. Conéctate o registrate

Ver el tema anterior Ver el tema siguiente Ir abajo  Mensaje [Página 1 de 1.]

1RESUELTO Descriobirme 2 formulas en el libro el 19/03/15, 01:53 am

JoaoM


Dejo libro para que me comenten con descripción 2 formulas; A14 y A15

Dentr ode las formulas esta explicita A1, me explican que tien que ver A1 en la formula y porque.

Pido para que NADA sea modificado, solo pido su explicación sobre lo aquí expuesto

Gracias
Archivos
Amortizacion de prestamos.zip
No tienes los permisos para descargar los archivos.
(30 KB)

wibly


Hola JoaoM,

Para resolver un problema existen muchísimas alternativas (te diría que infinitas)... y en tu caso, las fórmulas que tienes en la columna A desde la fila 14 sólo es una manera de hacerlo.

Por ejemplo, para la fila 23 la fórmula es
=SI(Y(A22<>"";FILAS($A$1:A9)<=$D$8 );FIN.MES(A22;1);"" )
y la parte que consultas, FILAS($A$1:A9), lo que hace es como decirte la cantidad de cuotas por encima de la fila 23, para que luego si este valor es mayor a la cantidad de "Número de cuotas" (celda D8) no ponga nada, lo que en la fórmula se representa con "".
En resumen, para lo que se usa la parte referida a A1 es solo para decidir si debe mostrar un cálculo o la celda debe quedar vacía.

La fórmula está bien, pero me parece que podría ser más simple su planteo y de más fácil interpretación la siguiente fórmula:

=SI(CONTAR(A$14:A22)<=$D$8;FIN.MES(A22;1);"" )

(esto sería para la celda A23)

Espero que te sea de utilidad.

Saludos

JoaoM


La formula de A15 adelante es la misma pero corrida hacia abajo, la diferencia que tienen es el # de línea de celda

La A15 hacia abajo es la misma solo que arrastrada hacia abajo, hasta la celda que corresponda a la celda D8.

En el rango A1:A13 nada hay y no va haber, por eso que pregunte que tiene que ver el rango A1:A13, en la formula A1:A11.
 No te parezca mal mi comentario, solo trato de entender la función de la formula, por eso mi contrarresta de tu explicación por si algo te escapa.

=SI(CONTAR(A$14:A22)<=$D$8;FIN.MES(A22;1);"" )

(esto sería para la celda A23)

Espero que te sea de utilidad.


Lo que comente arriba sobre la de A15 hacia abajo, es que tomaste una sorteada para dar tu explicación.

Es decir que si en A1 hay el rango A15: adelante no permanece vacío y vice-versa


Gracias amigo

Si algo te escapa, explica

=SI(Y(A22<>"";FILAS($A$1:A9)<=$D$8 );FIN.MES(A22;1);"" )


Veremos:  =SI(Y(A22<>"";  Si A22 es menor o maior entonces vacio si no lo del rango FILAS $A$1:A19 (A1 fijo para todas aunque arrastre la formula)

Teniendo el resultado del rango $A$1:A9 verifica si es menor o igual a $D$8
si es menor o igual  que  $D$8 entonces aplica el fin de mes de A22 + 1 si no vacio

Te pediría si puedes verificar si es correcto o no y si es negativo, corrige por favor

La (Y( que representa?





El o los signos < y >  <> ¿Qué representan? ¿maior o menor? (menor < maior >)
Será?

<= Menor o igual?

Perdona mi ignorancia

wibly


Hola JoaoM,

Me parece EXCELENTE que te interese entender las fórmulas ... yo muy dificilmente use una fórmula que no entienda, por más que me la haya pasado un experto. Si la responsabilidad del trabajo es mía debo entender la fórmula.

En cuanto a la consulta no entiendo gran parte de tu escrito, me cuesta entender sobre lo que pedís explicación.

Para comprender la fórmula lo mejor es leer la ayuda que te brinda el mismo EXCEL study.

En cuanto al uso de <>"" te paso un ejemplo:
Si tenemos la fórmula
=SI(A1<>"";"A";"B")
Le estamos indicando que cuando la celda A no está vacía el resultado a mostrar es "A" y en otro caso "B".

Por otro lado la Y sirve para evaluar varias condiciones simultáneamente. Acá la tienes dentro de una función SI, por lo que cuando se cumplan todas las condiciones que figuran dentro de la estructura del Y el resultado será el primer resultado del SI y de lo contrario irá la segunda... me resulta muy dificil explicar esto por este medio así que dudo que se entienda... te recomiendo leer la ayuda de cada una de las funciones y practicar con ejemplos de a una, porque si no las entiendes por separado más dificilmente puedas entender la fórmula que combina varias fórmulas.

Saludos

JoaoM


Hola Wibly, mis isalu2

Dices:
Me parece EXCELENTE que te interese entender las fórmulas ... yo muy dificilmente use una fórmula que no entienda, por más que me la haya pasado un experto. Si la responsabilidad del trabajo es mía debo entender la fórmula.

De eso se trata dentro de lo mio posible (lo mio posible ya es un tanto tarde, voy mui avnzado, pero en las primaveras)

En cuanto a la consulta no entiendo gran parte de tu escrito, me cuesta entender sobre lo que pedís explicación.
Solo es la descripción de la formula, algo como esto pero la formula completa.
=SI(Y(A22<>"";  Si A22 es menor o maior entonces vacio si no lo del rango FILAS $A$1:A19 (A1 fijo para todas aunque arrastre la formula) etc etc.
Una descripción del inicio al final de la formula

Para comprender la fórmula lo mejor es leer la ayuda que te brinda el mismo EXCEL .

En cuanto al uso de <>"" te paso un ejemplo:
Si tenemos la fórmula
=SI(A1<>"";"A";"B")
Le estamos indicando que cuando la celda A no está vacía el resultado a mostrar es "A" y en otro caso "B".
Lo de "" se lo que representa pero, y esto? <> ¿ y la Y?

Por otro lado la Y sirve para evaluar varias condiciones simultáneamente. Acá la tienes dentro de una función SI, por lo que cuando se cumplan todas las condiciones que figuran dentro de la estructura del Y el resultado será el primer resultado del SI y de lo contrario irá la segunda... me resulta muy dificil explicar esto por este medio así que dudo que se entienda...
Entendido perfectamente hasta esta parte. Los entre () se (y sabia) que es loque dentro de una formula se aplica en 1ª lugar tal como =SI(CONTAR(A$14:A22)<=$D$8;FIN.MES(A22;1);"" )
Quedo agradecido por tu explicación


Se puede cerrar el tema

Ver el tema anterior Ver el tema siguiente Volver arriba  Mensaje [Página 1 de 1.]

Permisos de este foro:
No puedes responder a temas en este foro.