UniversoExcelForo

Respuesta a consultas.
Fecha de creación: 09.Abril.2012

Fundadores: Wibly,Tyno,Servando,Sakkar,Rosendo2,RMaximo,Railar,Mcoronel,Ioyama,Igtelo,Hugotron,Drochar,Dedos,Alberto,Adolfo

No se pueden hacer consultas de Excel o VBA por mensaje privado.
Utiliza el botón buscar del foro y te ahorras tiempo para obtener "ayuda".

No estás conectado. Conéctate o registrate

Ver el tema anterior Ver el tema siguiente Ir abajo  Mensaje [Página 1 de 1.]

1RESUELTO Intervalos el 11/12/14, 10:52 am

Sombracan


Hola a todos/as
 
Necesito que en la columna C (Resultado) aparezca automáticamente el comentario de la columna I, según el resultado de la columna B (Valor de R2).
En la columna D (Debería dar) aparece el comentario que debería dar cuando se aplique la fórmula en la Columna C (Resultado)
 

Gracias
Archivos
Lugares y resultados.xls
No tienes los permisos para descargar los archivos.
(31 KB)

2RESUELTO Dos alternativas el 11/12/14, 02:18 pm

wibly


Hola Sombracan,

Te paso dos alternativas para hacerlo.

Una alternativa es usando varias funciones condicionales SI anidadas (ver columna E en el adjunto). Por ejemplo, para la fila 2 sería algo así:
Código:
=SI(CONTAR(B2)=1;SI(B2>=0,5;"Crecimiento acusado";SI(B2>=0,02;"Crecimiento moderado";SI(B2>=-0,02;"Estable";SI(B2>=-0,5;"Declive moderado";"Declive acusado"))));"")

Otra opción, que se justifica a medida que la cantidad de categorías se incrementa, es usa un BUSCARV para lo cual hay que definir correctamente la tabla de búsqueda (ver columna F y tabla en el rango H10:I15 en el adjunto). Por ejemplo, para la fila 2 sería algo así:

Código:
=SI.ERROR(BUSCARV(B2;$H$11:$I$15;2;1);"")


Si puedes lee la ayuda que brinda EXCEL sobre las dos funciones SI y BUSCARV, ya que son de gran utilidad.

Saludos
Archivos
Lugares y resultados adw.xls
No tienes los permisos para descargar los archivos.
(29 KB)

3RESUELTO Re: Intervalos el 14/12/14, 09:24 pm

wibly


Recuerden comentar si resolvieron el problema.
Sobracam, pudiste ver mis propuestas? Aguardo comentario.
Adrian

Ver el tema anterior Ver el tema siguiente Volver arriba  Mensaje [Página 1 de 1.]

Permisos de este foro:
No puedes responder a temas en este foro.