UniversoExcelForo

Respuesta a consultas.
Fecha de creación: 09.Abril.2012

Fundadores: Wibly,Tyno,Servando,Sakkar,Rosendo2,RMaximo,Railar,Mcoronel,Ioyama,Igtelo,Hugotron,Drochar,Dedos,Alberto,Adolfo

No se pueden hacer consultas de Excel o VBA por mensaje privado.
Utiliza el botón buscar del foro y te ahorras tiempo para obtener "ayuda".

No estás conectado. Conéctate o registrate

Ver el tema anterior Ver el tema siguiente Ir abajo  Mensaje [Página 1 de 1.]

Sombracan


Hola

Tengo columnas con años y nombre de personas.
Las columnas de años pueden tomar los siguientes valores:

0= la persona no se vacuna ese año.
1= La persona se vacuna ese año.
2= La persona ha fallecido

Me gustaría calcular:
1) El primer año de vacunación. ESO YA LO HE HECHO

2) El último año de vacunación.

3) El año de muerte

4) El número de años que ha estado esa persona con la vacunación. Es decir la diferencia entre el primer 1 y el último 1 (en caso de que todavía viva) o entre el primer 1 y el 2 (en caso de que haya fallecido).

Gracias
Archivos
Vacunaciones.xlsx
No tienes los permisos para descargar los archivos.
(10 KB)

railar


Hola Sombracan,

He tomado tu formula y le realicé una variante pequeña y es la misma que te va a servir para tus búsquedas.

Sólo cambiarás un número por lo que te recomiendo colocar un 1 para tu primera vacunación, un 2 para la segunda... y para la muerte puede ser un 5.

Realizado esta búsqueda solo te toca efectuar una resta, por ejemplo año de muerte - x vacunación

Esta es la formula para la primera vacunación con un 1 en el cuadro
Código:
=SI.ERROR(INDICE($C$1:$AJ$1;COINCIDIR(1;INDICE(ESNUMERO($C2:$AJ2)*($C2:$AJ2=1););));"No aplica")

y para el año de la muerte, colocando un 5 en tu cuadro
Código:
=SI.ERROR(INDICE(C$1:AJ$1;COINCIDIR(1;INDICE(ESNUMERO($C2:$AJ2)*($C2:$AJ2=5););));"No aplica")

Prueba y obtendras tus datos

Saludos,

Raúl

Sombracan


Muchas gracias

Un saludo

Ver el tema anterior Ver el tema siguiente Volver arriba  Mensaje [Página 1 de 1.]

Permisos de este foro:
No puedes responder a temas en este foro.