UniversoExcelForo

Respuesta a consultas.
Fecha de creación: 09.Abril.2012

Fundadores: Wibly,Tyno,Servando,Sakkar,Rosendo2,RMaximo,Railar,Mcoronel,Ioyama,Igtelo,Hugotron,Drochar,Dedos,Alberto,Adolfo

No se pueden hacer consultas de Excel o VBA por mensaje privado.
Utiliza el botón buscar del foro y te ahorras tiempo para obtener "ayuda".

No estás conectado. Conéctate o registrate

Ver el tema anterior Ver el tema siguiente Ir abajo  Mensaje [Página 1 de 1.]

1RESUELTO SUMAPRODUCTO el 16/07/12, 10:17 am

pedrot


Saludos excel-entes, soy nuevo.
Antes visitaba mundoexcel. Mi problema es:
1-En el archivo que adjunto(comprimido) problema al abrirlo con referencia circular.
2-Hasta que no llene todos los datos de la tabla(izquierda) no funciona el resumen(derecha). Pero si borre las formulas de los cuadros marcados en amarillos si funciona.
3- ¿Se puede buscar en sumaproducto por mas de una condición. ej:
SUMAPRODUCTOS(($C$7:$C$13=$M7)*($I$7:$I$13))*(1+J$4) estoy buscando solo por $M7.
Gracias de antemano.
Archivos
Calculo PLanchas.xls.zip
No tienes los permisos para descargar los archivos.
(105 KB)

2RESUELTO Re: SUMAPRODUCTOS el 16/07/12, 12:01 pm

pedrot


Saludos

Respecto al punto 3- ya conseguí la respuesta en:
'CONSULTAV() con doble condición' (ioyama da la respuesta)

Gracias

3RESUELTO Re: SUMAPRODUCTO el 16/07/12, 08:00 pm

hugotron


Que tal pedrot.

El problema son las fórmulas de las columnas I y J. Cambialas por éstas, y así ya funciona el resumen que generas con SUMAPRODUCTO().

Columna I: =SI(Y(B7<>"",H7>0),F7*H7,0)
Columna J: =SI(Y(G7>0,H7>0),G7*H7,0)

Como podrás notar, simplifiqué un poco las fórmulas usando un Y() en lugar de otro SI() como lo tenías anteriormente. El problema me parece que era que pedías a la fórmula SI que entregara "" si no se cumplian las condicionantes, lo correcto debía ser 0 pues SUMAPRODUCTO() no maneja valores alfanúmericos o textos. Lo puedes ver en el adjunto, espero sea lo que requieres.

Bueno, no sube el adjunto porque está más grande que el límite máximo de carga, y no tengo ZIP, tengo RAR, jajaja... Sólo cambia las fórmulas y quedará solucionado creo.

4RESUELTO Re: SUMAPRODUCTO el 16/07/12, 08:20 pm

hugotron


Bueno, SUMAPRODUCTO() si maneja textos y alfanúmericos, contrario a lo que mencionaba antes, los puede usar como criterios son problemas, he visto ejemplos. No sé a qué se deba el error anterior, aunque si queda solucionado con la corrección de las fórmulas que te pasé.

¡Saludos!

5RESUELTO Re: SUMAPRODUCTO el 16/07/12, 11:06 pm

Igtelo


Hola Pedrot / Hugo.

Respuestas
1.- No hay problema de referencia circular.

2.- En todos tus condicionales SI cambia blanco ("") por cero (0). Y ya te funciona como en el archivo.
Pero mejor utiliza las fórmulas que te dió Hugo, son sencillas y claras.

3.- Si puedes usar sumaproducto con varias condiciones de criterio, sólo que aquí nada más es uno. También puedes hacerlo con SUMAR.SI.

4.- En la celda F7 tenías una fórmula matricial, ya la quité.

5.- También consulta la ayuda de Excel: Corregir un error #Valor, ahí te explica todas las causas posibles.

6.- Eliminé tu hoja de pernos para hacer más liviano el archivo y poderlo subir.

Saludos
Ignacio Téllez
Archivos
Planchas.xls
No tienes los permisos para descargar los archivos.
(54 KB)

6RESUELTO Re: Sumaproductos el 17/07/12, 09:27 am

pedrot


Buenos días,tarde o noche

Muchas gracias Hugotron y Igtelo. Copiado y probado.

Problema resuelto.

Saludos Pedrot.

Ver el tema anterior Ver el tema siguiente Volver arriba  Mensaje [Página 1 de 1.]

Permisos de este foro:
No puedes responder a temas en este foro.