UniversoExcelForo

Respuesta a consultas.
Fecha de creación: 09.Abril.2012

Fundadores: Wibly,Tyno,Servando,Sakkar,Rosendo2,RMaximo,Railar,Mcoronel,Ioyama,Igtelo,Hugotron,Drochar,Dedos,Alberto,Adolfo

No se pueden hacer consultas de Excel o VBA por mensaje privado.
Utiliza el botón buscar del foro y te ahorras tiempo para obtener "ayuda".

No estás conectado. Conéctate o registrate

Ver el tema anterior Ver el tema siguiente Ir abajo  Mensaje [Página 1 de 1.]

1RESUELTO ayuda contar dos columnas criterios el 27/10/14, 05:28 am

emilioelbosque


Hola a todos, agradecimientos a todos los que hacéis posible la ayuda en este foro.

Necesito ayuda para resolver el siguiente problemas.

enfermo     patología
antonio      tos
bartolo       dolor
carlos        tos
daniel        disnea
carlos        dolor       
emilio         tos
carlos         tos
emilio         tos

Que formula puedo aplicar en excel para saber cuantos pacientes (sin repetir paciente) han tenido tos, que en este caso EL RESULTADO es 3.

Mil gracias anticipadas
El Bosque (Cádiz)

wibly


Hola Emilio, bienvenido al foro!

Te invito a que revises las NORMAS PARA EFECTUAR PREGUNTAS (ver yendo a INDICE). Es importante que subas un archivo de muestra con lo que tienes para poder ayudarte mejor.

En tu caso yo haría lo siguiente:
1- crear un campo auxiliar contatenando la información de ambos campos (se fueran las columnas A y B lo puedes ´hacer así: =A1&A2).
2- crear otro campo auxiliar en el que ponga 1 si esa combinación  no se encuentra en filas de arriba y 0 si es una combinación repetida (algo así: =SI(CONTAR.SI(C$2:C3;C4)=0;1;0)).
3- hacer una suma condicional del tipo: =SUMAPRODUCTO((B1:B10="tos")*(D1:D10))

Si tienes problemas para resolverlo, sube el archivo de muestra y lo implementamos.

Por último también te invito a que hagas una presentación como para hacer mas humana la comunidad (a qué te dedicas, intereses, conocimientos de Excel, por ejemplo), ver en sub-foro presentaciones.

Saludos

Adrián

wibly


Otra cosa, en Ubicación indicaste "el bosque", nos cuentas donde queda?, país?

emilioelbosque


Hola Wibly,

muy agradecido por tu amabilidad, pero no consigo resolver el problema.

Siguiendo tu consejo subo el archivo. Si puedes revisarlos. Mil gracias de nuevo



P.D.: Mi pequeño pueblo está en España!!
Archivos
prueba22.xls
No tienes los permisos para descargar los archivos.
(23 KB)

5RESUELTO Propuesta adw el 27/10/14, 09:42 am

wibly


Emilio,

Mira las celdas resaltadas en Naranja.

En el rango H12:I14 te dejo una propuesta como tabla resumen en la cual se calcula para todas las patologías.

Saludos

Adrián
Archivos
propuesta adw 20141027.xls
No tienes los permisos para descargar los archivos.
(24 KB)

ioyama


Hola

Otra opción sin columna auxiliar.

Hay que verificaral bien, en apariencia funciona.

Un saludo desde Vitoria
Archivos
ContarUnicos_io_141027.xls
No tienes los permisos para descargar los archivos.
(32 KB)

railar


Hola Emilio, 

Adrián e Ioyama, un Abrazo

Otra opción

Saludos

Raúl
Archivos
ContarUnicos_RI_20141027.xls
No tienes los permisos para descargar los archivos.
(31 KB)

emilioelbosque


Mil gracias a todos: Adrián, Ioyama y Raúl.

Pero en realidad los datos que manejo son de cientos de personas y decenas de patologías y poner más columnas auxiliares me complica mucho el trabajo.

SIGO buscando una solución como la situada en la celda D10, pero que admita textos.
SIGO BUSCANDO una fórmula situada solo en una celda.

De nuevo gracias por vuestro tiempo y amabilidad!!


Emilio (El Bosque- Cádiz)

emilioelbosque


PERDÓN PERDÓN, la fórmula de IOYAMA funciona perfectamente.

Al transcribir puse un dato mal. Una vez repasado FUNCIONAAAAA!!

Gracias de nuevo a todos!!


Saludos

Ver el tema anterior Ver el tema siguiente Volver arriba  Mensaje [Página 1 de 1.]

Permisos de este foro:
No puedes responder a temas en este foro.