UniversoExcelForo

Respuesta a consultas.
Fecha de creación: 09.Abril.2012

Fundadores: Wibly,Tyno,Servando,Sakkar,Rosendo2,RMaximo,Railar,Mcoronel,Ioyama,Igtelo,Hugotron,Drochar,Dedos,Alberto,Adolfo

No se pueden hacer consultas de Excel o VBA por mensaje privado.
Utiliza el botón buscar del foro y te ahorras tiempo para obtener "ayuda".

No estás conectado. Conéctate o registrate

Ver el tema anterior Ver el tema siguiente Ir abajo  Mensaje [Página 1 de 1.]

1 Macro comparar y copiar el 22/10/14, 04:40 am

JorgePlay


Buenos días.

A ver si me podéis ayudar con una macro de comparar y copiar.
He intentado utilizar algunas de las que ya habéis creado, pero no consigo realizarlo correctamente.

Gracias.
Archivos
Macro Comparar Referencia.xls
Macro comparar y copiar
No tienes los permisos para descargar los archivos.
(30 KB)

2 Re: Macro comparar y copiar el 22/10/14, 06:54 am

wibly


Hola JorgePlay,

No sé por qué pides una macro, yo te paso una propuesta usando la función BUSCARV, para lo cual lo que se requiere es poner en la 'hoja1' el campo 'Referencia' también como primer columna, por el funcionamiento de la función BUSCARV... y luego en la 'hoja2' se soluciona con funciones del tipo
=SI.ERROR(BUSCARV(B2;Hoja1!$A$2:$E$11;2;0);"")

Si puedes lee la ayuda sobre la función BUSCARV ya que es una función de gran utilidad. Puede ser que en un principio te cueste aplicarla pero con un poco de paciencia verás que no es tan dificil su manejo.

Te dejo un link de un video que grabé hace mucho, cuando no podía ponerle audio: VIDEO Función BUSCARV

Saludos

Adrián
Archivos
propuesta adw_20141022.zip
No tienes los permisos para descargar los archivos.
(8 KB)

3 Macro comparar y copiar el 22/10/14, 12:07 pm

JorgePlay


Buenas tardes wibly



Si pido una macro es porque intento hacerlo con una macro, pero no sé porqué no me la ejecuta adecuadamente.
No sé que estoy haciendo mal, si pudieras retornarme el archivo con una macro que ejecutara correctamente lo que planteo, te lo agradecería por dos motivos:
1) Para tenerla correctamente .
2) Para ver dónde diablos me estoy equivocando.

Ya no sé si el problema está en si me equivoco en el formato, si me equivoco en la sentencia o en qué me estoy equivocando (hay ocasiones en que la respuesta es tan sencilla y obvia, que por empecinamiento no nos damos cuenta del error)

Gracias por tu tiempo,

Un saludo

4 Re: Macro comparar y copiar el 22/10/14, 09:25 pm

wibly


En este momento no puedo ponerme a grabar la macro... si lo que planteé con fórmulas te sirve y sabes usar el grabador de macros te diria que intentes grabarla... No sé en que puede estar fallando la que tienes.

Adrián

5 Macro comparar y copiar el 23/10/14, 03:13 am

JorgePlay


wibly

Me siguen saliendo los campos en blanco.
De todas maneras gracias por tu tiempo.

Un saludo.

6 Re: Macro comparar y copiar el 24/10/14, 11:28 am

tyno


Hola Jorge, saludos Wibly.
Prueba el archivo Jorge. Saludos
Archivos
propuesta adw_20141022.zip
No tienes los permisos para descargar los archivos.
(16 KB)

Ver el tema anterior Ver el tema siguiente Volver arriba  Mensaje [Página 1 de 1.]

Permisos de este foro:
No puedes responder a temas en este foro.