UniversoExcelForo

Respuesta a consultas.
Fecha de creación: 09.Abril.2012

Fundadores: Wibly,Tyno,Servando,Sakkar,Rosendo2,RMaximo,Railar,Mcoronel,Ioyama,Igtelo,Hugotron,Drochar,Dedos,Alberto,Adolfo

No se pueden hacer consultas de Excel o VBA por mensaje privado.
Utiliza el botón buscar del foro y te ahorras tiempo para obtener "ayuda".

No estás conectado. Conéctate o registrate

Ver el tema anterior Ver el tema siguiente Ir abajo  Mensaje [Página 1 de 1.]

ANDESTEBAN


muy buen día a todos, estoy trabado con la ultima parte de mi excel, quería ver si alguien podía ayudarme

estoy intentando hacer que mi hoja de asistencia(MarioReyes.xlsx) se rellene automáticamente con valores existentes de otra hoja(contrato.xlsx) al cumplir la condición de que el ingreso manual coincida con la columna C.COSTO de (contrato.xlsx)


por ejemplo,

al ingresar en D2 el C.COSTO, en este caso, SAN PABLO (3072), debiese desplegarse en D10: D59 la lista de todos los ítems que contengan SAN PABLO(3072) en contrato.xlsx


yo lo hice por llamada directa, pero queda mal hecha porque al pasar de la cantidad pone los otros ítems, después probé don DBEXTRAER pero ese solo me saca un item, creo que hay algo con la formula INDICE pero la verdad es que no se utilizarla.

espero me puedan ayudar, saludos!

subo mis adjuntos comentados.
Archivos
excel.zip
No tienes los permisos para descargar los archivos.
(48 KB)

DEDOS


Hola buen día:

Te adjunto un archivo con la fórmula que quieres, en la hoja2, va un pequeño detalle que debes de hacer en el libro contrato.

En la hoja San Pablo (3072) en la celda D10, inserta esta fórmula matricial {=INDICE(Hoja2!B:F,K.ESIMO.MENOR(SI(DESREF(Hoja2!B:F,0,0,FILAS(Hoja2!B:F),1)=$D$2,FILA(DESREF(Hoja2!B:F,0,0,FILAS(Hoja2!B:F),1))-FILA(DESREF(Hoja2!B:F,0,1,1,1))+1,FILA(DESREF(Hoja2!B:F,FILAS(Hoja2!B:F)-1,0,1,1))+1),C10),5)}
y en la celda E10 {=INDICE(Hoja2!B:F,K.ESIMO.MENOR(SI(DESREF(Hoja2!B:F,0,0,FILAS(Hoja2!B:F),1)=$D$2,FILA(DESREF(Hoja2!B:F,0,0,FILAS(Hoja2!B:F),1))-FILA(DESREF(Hoja2!B:F,0,1,1,1))+1,FILA(DESREF(Hoja2!B:F,FILAS(Hoja2!B:F)-1,0,1,1))+1),C10),3)}, pero, debes de cambiar a la columna "B" el "c.costo"
En ésta parte "Hoja2!B:F", debes sustituirla por la dirección donde se encuentre tu libro contrato el cual debes de tener abierto.


Saludos y suerte



Última edición por DEDOS el 24/08/14, 12:25 am, editado 2 veces (Razón : no me deja subir el archivo)

Igtelo


Hola Andesteban /Charlie.

No he visto el archivo pero por la fórmula, esto es una maestría.
Gracias Dedos!!!! Fórmulas y matriciales...

Por favor trata de nuevo a subir el archivo, sino te deja dime que error manda y ya vemos...

Saludos
Ignacio Téllez

DEDOS


Hola:
Te envío tu archivo con modificaciones.
saludos y suerte
Archivos
contrato.zip
No tienes los permisos para descargar los archivos.
(36 KB)

Ver el tema anterior Ver el tema siguiente Volver arriba  Mensaje [Página 1 de 1.]

Permisos de este foro:
No puedes responder a temas en este foro.