UniversoExcelForo

Respuesta a consultas.
Fecha de creación: 09.Abril.2012

Fundadores: Wibly,Tyno,Servando,Sakkar,Rosendo2,RMaximo,Railar,Mcoronel,Ioyama,Igtelo,Hugotron,Drochar,Dedos,Alberto,Adolfo

No se pueden hacer consultas de Excel o VBA por mensaje privado.
Utiliza el botón buscar del foro y te ahorras tiempo para obtener "ayuda".

No estás conectado. Conéctate o registrate

Ver el tema anterior Ver el tema siguiente Ir abajo  Mensaje [Página 1 de 1.]

jhon1904


hola, amigos de excel

necesito una formula la cual me ubique los numeros del 0 hasta 9, en un orden de mayor a menor segun las veces que se repita cada numero

gracias

saludos

jhon borja
Archivos
Organizar.zip
No tienes los permisos para descargar los archivos.
(11 KB)

2RESUELTO Propuestas el 21/08/14, 07:44 am

wibly


Hola Jhon!

Esta bien la idea de usar la función K.ESIMO.MAYOR. El tema en estos casos son los casos 'repetidos'. Por ejemplo en tu caso tanto el 0 como el 7 tenés que se repiten 2 veces. Entonces, ¿cual vas a poner primero?

Mi idea en estos casos es crear un campo auxiliar al cual sumar al campo original una cte diferente para cada fila, que puede ser por ejemplo =B4+FILA(B4)/1000000, para de esta manera tener todos valores únicos.

Luego lo que te puede ayudar es combinar las funciones INCIDE, COINCIDIR... algo así como esto
=INDICE($A$4:$A$13;COINCIDIR(K.ESIMO.MAYOR($J$4:$J$13;K4);$J$4:$J$13;0)).

Mira la propuesta en el adjunto y dime si eso te sirve.

Todo esto si lo quieres con fórmula, porque sino macro con ORDENAR y listo.

Un abrazo!

Adrián
Archivos
Organizar adw.zip
No tienes los permisos para descargar los archivos.
(16 KB)



Última edición por wibly el 21/08/14, 07:49 am, editado 1 vez (Razón : subida de archivo)

ioyama


Hola jhon

El problema está en las cantidades repetidas, de lo contrario con INDICE y COINCIDIR sería suficiente.

No obstante si usamos una columna auxiliar..... podemos seguir usando dichas funciones.

Revisa el archivo.

Fila()/999999999 lo único que hace es sumar un número muy pequeño a cada cantidad a fin de diferenciar dos que sean iguales por la fila que ocupan.

Un saludo desde Vitoria

Wibly(un saludo por cierto) ha respondido hace un momento (mientras te ponía el ejemplo)
Archivos
OrdenarSegúnCantidad_io_140821.xls
No tienes los permisos para descargar los archivos.
(30 KB)

wibly


Hola iyama!!!,

Me alegra que coincidamos... es un buen artificio para generar "valores únicos".

Un abrazo!

Adrián

jhon1904


hola, ioyama y adrian


la verdad le había matado mucha cabeza ha esta forma de ordenar con formulas, no quería utilizar macros si no formulas en excel, tenia la idea pero no la había complementado, no habia utilizado la función fila en una columna auxiliar.


gracias por su tiempo y por su colaboracion, son unos expertos en formulas, es loq ue necesitaba

saludos

jhon borja

Ver el tema anterior Ver el tema siguiente Volver arriba  Mensaje [Página 1 de 1.]

Permisos de este foro:
No puedes responder a temas en este foro.